miniupnpd: Fix UUID dependency not to check outside the tree, and use uuid always.
[feed/routing.git] / miniupnpd / patches / 101-no-ssl-uuid.patch
diff --git a/miniupnpd/patches/101-no-ssl-uuid.patch b/miniupnpd/patches/101-no-ssl-uuid.patch
new file mode 100644 (file)
index 0000000..03a4966
--- /dev/null
@@ -0,0 +1,25 @@
+We do not need to autodetect SSL/UUID; SSL we do not support, UUID we always do.
+
+diff --git a/miniupnpd/Makefile.linux b/miniupnpd/Makefile.linux
+index 2d28126..01daeea 100644
+--- a/Makefile.linux
++++ b/Makefile.linux
+@@ -153,14 +153,18 @@ LDLIBS += $(shell $(PKG_CONFIG) --static --libs-only-l libmnl)
+ LDLIBS += $(shell $(PKG_CONFIG) --static --libs-only-l libnetfilter_conntrack)
+ endif # ($(TEST),1)
++ifeq ($(TARGET_OPENWRT),)
++# n/a - we don't enable https server for IGD v2 anyway in OpenWrt
+ LDLIBS += $(shell $(PKG_CONFIG) --static --libs-only-l libssl)
++# n/a - we hardcodedly support libuuid
+ TEST := $(shell $(PKG_CONFIG) --exists uuid && echo 1)
+ ifeq ($(TEST),1)
+ LDLIBS += $(shell $(PKG_CONFIG) --static --libs-only-l uuid)
+ else
+ $(info please install uuid-dev package / libuuid)
+ endif # ($(TEST),1)
++endif
+ TESTUPNPDESCGENOBJS = testupnpdescgen.o upnpdescgen.o