grilo-plugins: update to 0.3.10 and build with meson
[feed/packages.git] / multimedia / grilo-plugins / Makefile
index 632fe4de4b7c664e56f8b590939748484d38e7e5..b976b42c9e91a2cadcda4fe6674f333666c8c024 100644 (file)
@@ -6,8 +6,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=grilo-plugins
-PKG_VERSION:=0.3.7
-PKG_RELEASE:=3
+PKG_VERSION:=0.3.10
+PKG_RELEASE:=1
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
 PKG_LICENSE:=LGPLv2.1
@@ -15,14 +15,15 @@ PKG_LICENSE_FILES:=COPYING
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNOME/grilo-plugins/0.3/
-PKG_HASH:=fc2f3bbc319136e53e1efb6659fa65b6af45db114b6621008f9abba64fad6820
+PKG_HASH:=803b360fdb6d5fde1e647bdc40c16de3031b1a95b347b48b65fe4fc27a548d4a
 
 PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
-PKG_FIXUP:=autoreconf
+PKG_BUILD_DEPENDS:=meson/host
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/nls.mk
+include ../../devel/meson/meson.mk
 
 define Package/grilo-plugins/Default
   SECTION:=multimedia
@@ -44,28 +45,23 @@ define Package/grilo/decription
   plugins to get information from a number of sources.
 endef
 
-CONFIGURE_ARGS += \
-        --enable-static \
-        --disable-compile-warnings \
-        --disable-goa \
-        --disable-filesystem \
-        --disable-optical-media \
-        --disable-youtube \
-        --disable-flickr \
-        --disable-podcasts \
-        --disable-bookmarks \
-        --disable-lua-factory \
-        --disable-metadata-store \
-        --disable-vimeo \
-        --disable-tracker \
-        --disable-local-metadata \
-        --disable-chromaprint \
-        --disable-thetvdb \
-        --disable-tmdb \
-        --disable-freebox
-
-MAKE_FLAGS += \
-        GLIB_COMPILE_RESOURCES="$(STAGING_DIR_HOSTPKG)/bin/glib-compile-resources"
+MESON_ARGS += \
+       -Denable-filesystem=no \
+       -Denable-optical-media=no \
+       -Denable-youtube=no \
+       -Denable-flickr=no \
+       -Denable-podcasts=no \
+       -Denable-bookmarks=no \
+       -Denable-lua-factory=no \
+       -Denable-metadata-store=no \
+       -Denable-vimeo=no \
+       -Denable-tracker=no \
+       -Denable-local-metadata=no \
+       -Denable-chromaprint=no \
+       -Denable-thetvdb=no \
+       -Denable-tmdb=no \
+       -Denable-freebox=no \
+
 define Package/grilo-plugins/install
        $(INSTALL_DIR) $(1)/usr/lib/grilo-0.3
 endef