gst1-plugins-ugly: Disable debug + other fixes
[feed/packages.git] / multimedia / gst1-plugins-ugly / Makefile
index bb8119ff06700822e9a7c4c0e1356cbc89f6cab3..b1dbf85fa3db337bbe05bc4e452bb0df6756c4f7 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gst1-plugins-ugly
 PKG_VERSION:=1.15.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
                Ted Hess <thess@kitschensync.net>
@@ -27,6 +27,7 @@ PKG_CONFIG_DEPENDS:= \
        CONFIG_PACKAGE_gst1-mod-mpeg2dec \
 
 PKG_FIXUP:=autoreconf
+PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -96,6 +97,12 @@ GST_VERSION:=1.0
 CONFIGURE_ARGS += \
        --disable-debug \
        --disable-examples \
+       --disable-fatal-warnings \
+       --disable-glib-asserts \
+       --disable-gobject-cast-checks \
+       --disable-gtk-doc-html \
+       --disable-valgrind \
+       --disable-rpath \
        \
        --disable-a52dec \
        --disable-amrnb \
@@ -117,13 +124,7 @@ CONFIGURE_ARGS += \
        \
        --without-libiconv-prefix \
        --without-libintl-prefix \
-
-TARGET_CFLAGS += -Wno-format-nonliteral
-
-EXTRA_LDFLAGS+= \
-       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
-       $(if $(ICONV_FULL),-liconv) \
-
+       --with-pic
 
 define Package/gst1-plugins-ugly/install
        /bin/true