fping: Set -std=gnu99 to fix build errors due to C99 constructs
[feed/packages.git] / net / fping / Makefile
index 0591b6fd28f080da5d94285018eebf177b78c9aa..b0f3ae72227055d128ce36d0157197c3f5cf310e 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fping
 PKG_VERSION:=4.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://fping.org/dist/
@@ -44,6 +44,8 @@ CONFIGURE_ARGS+= \
        --enable-ipv4 \
        --enable-ipv6
 
+TARGET_CFLAGS += -std=gnu99
+
 define Package/fping/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/fping $(1)/usr/bin/