freeradius3: Remove Python 2 module package
[feed/packages.git] / net / freeradius3 / Makefile
index 62dbe21fbe8ca7dbcba6dad4259829f03e92a9fb..ef32b33ccd93db81eada3be253805405de0dc264 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=freeradius3
 PKG_VERSION:=release_3_0_20
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/FreeRADIUS/freeradius-server/archive
@@ -30,7 +30,6 @@ PKG_CONFIG_DEPENDS := \
 CFLAGS += $(FPIC)
 
 include $(INCLUDE_DIR)/package.mk
-include $(TOPDIR)/feeds/packages/lang/python/python-package.mk
 include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
 
 define Package/freeradius3/config
@@ -342,16 +341,6 @@ define Package/freeradius3-mod-preprocess/conffiles
 /etc/freeradius3/mods-enabled/preprocess
 endef
 
-define Package/freeradius3-mod-python
-  $(call Package/freeradius3/Default)
-  DEPENDS:=freeradius3 +python
-  TITLE:=Python module
-endef
-
-define Package/freeradius3-mod-python/conffiles
-/etc/freeradius3/mods-available/python
-endef
-
 define Package/freeradius3-mod-python3
   $(call Package/freeradius3/Default)
   DEPENDS:=freeradius3 +python3
@@ -512,6 +501,7 @@ CONFIGURE_ARGS+= \
        --without-rlm_opendirectory \
        --without-rlm_pam \
        --without-rlm_perl \
+       --without-rlm_python \
        --without-rlm_redis \
        --without-rlm_rediswho \
        --without-rlm_rest \
@@ -577,19 +567,6 @@ else
   CONFIGURE_ARGS+= --without-rlm_eap_pwd
 endif
 
-ifneq ($(SDK)$(CONFIG_PACKAGE_freeradius3-mod-python),)
-  CFLAGS+= -fPIC
-  CONFIGURE_ARGS+= \
-               --with-rlm_python \
-               --with-rlm-python-include-dir="$(PYTHON_INC_DIR)" \
-               --with-rlm-python-lib-dir="$(PYTHON_LIB_DIR)"
-  CONFIGURE_VARS+= \
-               OPENWRTTARGET_PY_PREFIX="$(PYTHON_DIR)" \
-               OPENWRTTARGET_PY_SYS_VERSION="$(PYTHON_VERSION)"
-else
-  CONFIGURE_ARGS+= --without-rlm_python
-endif
-
 ifneq ($(SDK)$(CONFIG_PACKAGE_freeradius3-mod-python3),)
   CFLAGS+= -fPIC
   CONFIGURE_ARGS+= \
@@ -789,8 +766,6 @@ $(eval $(call BuildPlugin,freeradius3-mod-mschap,rlm_mschap,))
 $(eval $(call BuildPlugin,freeradius3-mod-pap,rlm_pap,))
 $(eval $(call BuildPlugin,freeradius3-mod-passwd,rlm_passwd,))
 $(eval $(call BuildPlugin,freeradius3-mod-preprocess,rlm_preprocess,))
-$(eval $(call PyPackage,freeradius3-mod-python))
-$(eval $(call BuildPlugin,freeradius3-mod-python,rlm_python,))
 $(eval $(call Py3Package,freeradius3-mod-python3))
 $(eval $(call BuildPlugin,freeradius3-mod-python3,rlm_python3,))
 $(eval $(call BuildPlugin,freeradius3-mod-radutmp,rlm_radutmp,))