net-snmp: move to PCRE2 library
[feed/packages.git] / net / net-snmp / Makefile
index b700e47619b8b84ec5a866c96e060d5fed702f61..46aa5e2735101770db341e619c0e32d6593826b9 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=net-snmp
 PKG_VERSION:=5.9.1
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/net-snmp
@@ -41,7 +41,7 @@ define Package/libnetsnmp
 $(call Package/net-snmp/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libnl-tiny +libpci +libpcre
+  DEPENDS:=+libnl-tiny +libpci +libpcre2
   TITLE:=Open source SNMP implementation (libraries)
 endef
 
@@ -208,6 +208,7 @@ CONFIGURE_ARGS += \
        --without-mysql \
        --without-rpm \
        --without-zlib \
+       --with-pcre2-8 \
        --with-nl \
         $(call autoconf_bool,CONFIG_IPV6,ipv6) \
        --disable-perl-cc-checks \