ola: fix compilation with older clang
[feed/packages.git] / net / ola / patches / 010-no-werror.patch
diff --git a/net/ola/patches/010-no-werror.patch b/net/ola/patches/010-no-werror.patch
new file mode 100644 (file)
index 0000000..44f5bdb
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -61,7 +61,7 @@ COMMON_TESTING_PROTOBUF_FLAGS = $(COMMON
+ # The generated protobuf files don't compile with -Werror on win32 so we
+ # disable fatal warnings on WIN32.
+-if ! USING_WIN32
++if USING_WIN32
+ if FATAL_WARNINGS
+   COMMON_CXXFLAGS += -Werror
+   COMMON_PROTOBUF_CXXFLAGS += -Werror -Wno-error=unused-parameter \