pppossh: new package for network proto "pppossh"
[feed/packages.git] / net / pppossh / Makefile
diff --git a/net/pppossh/Makefile b/net/pppossh/Makefile
new file mode 100644 (file)
index 0000000..5dc74e2
--- /dev/null
@@ -0,0 +1,38 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pppossh
+PKG_RELEASE:=1
+PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
+PKG_LICENSE:=GPLv2
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/pppossh
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=PPPoSSH (Point-to-Point Protocol over SSH)
+  URL:=https://github.com/yousong/waller
+  DEPENDS:=+ppp +resolveip @(PACKAGE_dropbear||PACKAGE_openssh-client)
+endef
+
+define Package/pppossh/description
+This package adds protocol support for PPP over SSH.  The protocol name is
+'pppossh' as in netifd interface config option 'proto'.
+endef
+
+define Build/Compile
+endef
+
+define Package/pppossh/install
+       $(INSTALL_DIR) $(1)/lib/netifd/proto
+       $(INSTALL_BIN) ./files/pppossh.sh $(1)/lib/netifd/proto
+endef
+
+$(eval $(call BuildPackage,pppossh))