various patches
[openwrt/svn-archive/archive.git] / obsolete-buildroot / sources / openwrt / ipkg / libpthread / CONTROL / rules
diff --git a/obsolete-buildroot/sources/openwrt/ipkg/libpthread/CONTROL/rules b/obsolete-buildroot/sources/openwrt/ipkg/libpthread/CONTROL/rules
new file mode 100755 (executable)
index 0000000..9f742d4
--- /dev/null
@@ -0,0 +1,34 @@
+#!/usr/bin/make -f
+
+ifeq ($(strip $(TOPDIR)),)
+TOPDIR := $(shell pwd)/../../../..
+endif
+
+
+# variables extracted from $(TOPDIR)/Makefile
+ARCH:= mipsel
+STAGING_DIR=$(TOPDIR)/build_$(ARCH)/staging_dir
+REAL_GNU_TARGET_NAME=$(ARCH)-linux-uclibc
+TARGET_CROSS=$(STAGING_DIR)/bin/$(REAL_GNU_TARGET_NAME)-
+STRIP=$(TARGET_CROSS)strip --remove-section=.comment --remove-section=.note
+# could be better if replaced with:
+#include $(TOPDIR)/Config
+
+
+PACKAGE := libpthread
+
+MY_INSTALL_DIR := /tmp/$(PACKAGE)
+
+
+build:
+
+
+install:
+       rm -rf $(MY_INSTALL_DIR)
+       install -m0755 -d $(MY_INSTALL_DIR)/lib
+       install -m0755 $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/lib/libpthread-0.9.26.so $(MY_INSTALL_DIR)/lib
+       $(STRIP) $(MY_INSTALL_DIR)/lib/libpthread*.so*
+       ln -fs libpthread-0.9.26.so $(MY_INSTALL_DIR)/lib/libpthread.so.0
+
+clean:
+