convert bridge package to buildroot-ng
[openwrt/openwrt.git] / openwrt / package / bridge / Makefile
index 44b22cd7225773a7062e5e620e63bca4e5cf37a5..be52b2a9754229b54474944b64662e07b92df1f9 100644 (file)
@@ -5,18 +5,26 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=bridge
 PKG_VERSION:=1.0.6
 PKG_RELEASE:=1
-PKG_MD5SUM:=9b7dc52656f5cbec846a7ba3299f73bd
 
-PKG_SOURCE_URL:=@SF/bridge
-PKG_SOURCE:=bridge-utils-$(PKG_VERSION).tar.gz
 PKG_BUILD_DIR:=$(BUILD_DIR)/bridge-utils-$(PKG_VERSION)
+PKG_SOURCE:=bridge-utils-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/bridge
+PKG_MD5SUM:=9b7dc52656f5cbec846a7ba3299f73bd
 PKG_CAT:=zcat
 
 include $(TOPDIR)/package/rules.mk
-$(eval $(call PKG_template,BRIDGE,bridge,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-$(PKG_BUILD_DIR)/.configured:
-       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+define Package/bridge
+SECTION:=base
+CATEGORY:=Network
+DEFAULT:=y
+TITLE:=Ethernet bridging configuration utility
+DESCRIPTION:=Manage ethernet bridging; a way to connect networks together to\\\
+form a larger network.
+URL:=http://bridge.sourceforge.net/
+endef
+
+define Build/Configure
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
                ./configure \
@@ -34,16 +42,20 @@ $(PKG_BUILD_DIR)/.configured:
                --mandir=/usr/man \
                --infodir=/usr/info \
                $(DISABLE_NLS) \
-               --with-linux-headers=$(LINUX_DIR) \
-       );
-       touch $@
+               --with-linux-headers=$(LINUX_DIR)
+endef
 
-$(PKG_BUILD_DIR)/.built:
+
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)
        touch $@
+endef
 
-$(IPKG_BRIDGE): 
+define Package/busybox/install
        mkdir -p $(IDIR_BRIDGE)/usr/sbin
-       cp $(PKG_BUILD_DIR)/brctl/brctl $(IDIR_BRIDGE)/usr/sbin/
+       $(CP) $(PKG_BUILD_DIR)/brctl/brctl $(IDIR_BRIDGE)/usr/sbin/
        $(STRIP) $(IDIR_BRIDGE)/usr/sbin/brctl
        $(IPKG_BUILD) $(IDIR_BRIDGE) $(PACKAGE_DIR)
+endef
+
+$(eval $(call BuildPackage,bridge))