lots of small package changes and dependency cleanups for the V= stuff
[openwrt/svn-archive/archive.git] / openwrt / package / cyrus-sasl / Makefile
index 2729883102191c57bd881f5915cc3723a4cfb4de..84238db55d1e87ae65296110d86545c7754bbb7c 100644 (file)
@@ -18,7 +18,7 @@ include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,LIBSASL2,libsasl2,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+$(PKG_BUILD_DIR)/.configured:
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
@@ -123,5 +123,5 @@ uninstall-dev:
        rm -rf $(STAGING_DIR)/usr/lib/libsasl{2,}.{a,so*}
        rm -rf $(STAGING_DIR)/usr/lib/sasl2
 
-compile: install-dev
-clean: uninstall-dev
+compile-targets: install-dev
+clean-targets: uninstall-dev