Convert packages to new template
[openwrt/staging/dedeckeh.git] / openwrt / package / mtd / Makefile
index 61e7e74c232e3d3db71d6b487c101ad2c5e857a5..381184b1d3e2ccd77f1ce3bb5da55a832c71d8f5 100644 (file)
@@ -9,29 +9,20 @@ PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
 include $(TOPDIR)/package/rules.mk
 
-$(eval $(call PKG_template,MTD,$(PKG_NAME),$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,MTD_STATIC,mtd-static,$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.prepared:
-       mkdir -p $(PKG_BUILD_DIR)
-       touch $@
-
-$(PKG_BUILD_DIR)/.configured:
-       touch $@
-
-$(PKG_BUILD_DIR)/.built:
+define Package/mtd
+SECTION:=base
+CATEGORY:=Util
+DEFAULT:=y
+TITLE:=Update utility for trx firmware images
+DESCRIPTION:=Update utility for trx firmware images. To update \\\
+from other firmware or older OpenWrt releases.
+endef
+
+define Build/Compile
        $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mtd mtd.c
-       $(TARGET_CC) -static $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mtd-static mtd.c
-       touch $@
+endef
 
-$(IPKG_MTD): 
+define Package/mtd/install
        install -d -m0755 $(IDIR_MTD)/sbin
        install -m0755 $(PKG_BUILD_DIR)/mtd $(IDIR_MTD)/sbin
-       $(RSTRIP) $(IDIR_MTD)/sbin/*
-       $(IPKG_BUILD) $(IDIR_MTD) $(PACKAGE_DIR)
-
-$(IPKG_MTD_STATIC): 
-       install -d -m0755 $(IDIR_MTD_STATIC)/sbin
-       install -m0755 $(PKG_BUILD_DIR)/mtd-static $(IDIR_MTD_STATIC)/sbin
-       $(RSTRIP) $(IDIR_MTD_STATIC)/sbin/*
-       $(IPKG_BUILD) $(IDIR_MTD_STATIC) $(PACKAGE_DIR)
+endef