cleanup; change base-files build directory
[openwrt/staging/dedeckeh.git] / openwrt / package / rules.mk
index 50f03effae5a9a7c409983375c03c2ae8b0bab75..26b41969d9df57ec360a4c3f5baab6b1aad64339 100644 (file)
@@ -154,8 +154,9 @@ define BuildPackage
   $$(IPKG_$(1)): $$(IDIR_$(1))/CONTROL/control $(PKG_BUILD_DIR)/.built
        $(call Package/$(1)/install,$$(IDIR_$(1)))
        mkdir -p $(PACKAGE_DIR)
-       find $$(IDIR_$(1)) -name CVS | xargs rm -rf
-       find $$(IDIR_$(1)) -name .svn | xargs rm -rf
+       -find $$(IDIR_$(1)) -name CVS | xargs rm -rf
+       -find $$(IDIR_$(1)) -name .svn | xargs rm -rf
+       -find $$(IDIR_$(1)) -name '.#*' | xargs rm -f
        $(RSTRIP) $$(IDIR_$(1))
        $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)