cleanup; change base-files build directory
[openwrt/staging/dedeckeh.git] / openwrt / package / rules.mk
index e5df61e1774d85ce27766432b1ba338805a4b2ff..26b41969d9df57ec360a4c3f5baab6b1aad64339 100644 (file)
@@ -5,9 +5,14 @@ else
 endif
 
 define Build/DefaultTargets
+  ifeq ($(DUMP),)
+    ifeq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) . | tee /tmp/xy1),.)
+      $(PKG_BUILD_DIR)/.prepared: package-clean
+    endif
 
-  ifeq ($(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) .),.)
-    $(PKG_BUILD_DIR)/.prepared: package-clean
+    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $(IPKG_$(1)) $(PKG_BUILD_DIR) | tee /tmp/xy2),$(IPKG_$(1)))
+      $(PKG_BUILD_DIR)/.built: package-rebuild
+    endif
   endif
 
   $(PKG_BUILD_DIR)/.prepared: $(DL_DIR)/$(PKG_SOURCE)
@@ -20,13 +25,20 @@ define Build/DefaultTargets
        $(call Build/Configure)
        touch $$@
 
-  built: FORCE $(PKG_BUILD_DIR)/.configured
-    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $(IPKG_$(1)) $(PKG_BUILD_DIR)),$(IPKG_$(1)))
+  $(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
        $(call Build/Compile)
-    endif
-
+       touch $$@
+    
+  $(PKG_BUILD_DIR)/.dev-installed: $(PKG_BUILD_DIR)/.built
+       $(call Build/InstallDev)
+       touch $$@
+    
   package-clean: FORCE
        $(call Build/Clean)
+       $(call Build/UninstallDev)
+
+  package-rebuild: FORCE
+       @-rm $(PKG_BUILD_DIR)/.built
 
   define Build/DefaultTargets
   endef
@@ -70,16 +82,12 @@ define BuildPackage
   IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(1)
   INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
 
-  ifneq ($(CONFIG_PACKAGE_$(1))$(DEVELOPER),)
-    COMPILE_$(1):=1
-  endif
-
   ifeq ($(CONFIG_PACKAGE_$(1)),y)
     install-targets: $$(INFO_$(1))
   endif
 
-  ifneq ($(COMPILE_$(1)),)
-    compile-targets: $(IPKG_$(1))
+  ifneq ($(CONFIG_PACKAGE_$(1))$(DEVELOPER),)
+    compile-targets: $$(IPKG_$(1))
   endif
 
   IDEPEND_$(1):=$$(strip $$(DEPENDS))
@@ -100,6 +108,7 @@ define BuildPackage
   DUMPINFO += \
        echo "Version: $(VERSION)"; \
        echo "Depends: $$(IDEPEND_$(1))"; \
+       echo "Build-Depends: $(PKG_BUILDDEP)"; \
        echo "Category: $(CATEGORY)"; \
        echo "Title: $(TITLE)"; \
        echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n,g';
@@ -113,11 +122,24 @@ define BuildPackage
   DUMPINFO += \
        echo "@@";
 
+  ifneq ($(CONFIG),)
+    DUMPINFO += \
+       echo "Config: $(CONFIG)" | sed -e 's,\\,\n,g'; \
+       echo "@@";
+  endif
+
   $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
        mkdir -p $$(IDIR_$(1))/CONTROL
        echo "Package: $(1)" > $$(IDIR_$(1))/CONTROL/control
        echo "Version: $(VERSION)" >> $$(IDIR_$(1))/CONTROL/control
-       echo "Depends: $$(IDEPEND_$(1))" >> $$(IDIR_$(1))/CONTROL/control
+       ( \
+               DEPENDS=; \
+               for depend in $$(IDEPEND_$(1)); do \
+                       [ "$$$${depend%%%%%%%%[A-Za-z]*}" = "@" ] && continue; \
+                       DEPENDS=$$$${DEPENDS:+$$$$DEPENDS, }$$$${depend##+}; \
+               done; \
+               echo "Depends: $$$$DEPENDS" >> $$(IDIR_$(1))/CONTROL/control; \
+       )
        echo "Source: $(SOURCE)" >> $$(IDIR_$(1))/CONTROL/control
        echo "Section: $(SECTION)" >> $$(IDIR_$(1))/CONTROL/control
        echo "Priority: $(PRIORITY)" >> $$(IDIR_$(1))/CONTROL/control
@@ -129,9 +151,12 @@ define BuildPackage
                [ -f ./ipkg/$(1).$$$$file ] && cp ./ipkg/$(1).$$$$file $$(IDIR_$(1))/CONTROL/$$$$file || true; \
        done
 
-  $$(IPKG_$(1)): $$(IDIR_$(1))/CONTROL/control built
+  $$(IPKG_$(1)): $$(IDIR_$(1))/CONTROL/control $(PKG_BUILD_DIR)/.built
        $(call Package/$(1)/install,$$(IDIR_$(1)))
        mkdir -p $(PACKAGE_DIR)
+       -find $$(IDIR_$(1)) -name CVS | xargs rm -rf
+       -find $$(IDIR_$(1)) -name .svn | xargs rm -rf
+       -find $$(IDIR_$(1)) -name '.#*' | xargs rm -f
        $(RSTRIP) $$(IDIR_$(1))
        $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
 
@@ -143,9 +168,7 @@ define BuildPackage
 
   clean: $(1)-clean
 
-  ifneq ($(__DEFAULT_TARGETS),1)
-    $$(eval $$(call Build/DefaultTargets,$(1)))
-  endif
+  $$(eval $$(call Build/DefaultTargets,$(1)))
 
 endef
 
@@ -176,10 +199,14 @@ define Build/Configure/Default
        [ -x configure ] && \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                ./configure \
                --target=$(GNU_TARGET_NAME) \
                --host=$(GNU_TARGET_NAME) \
                --build=$(GNU_HOST_NAME) \
+               --program-prefix="" \
+               --program-suffix="" \
                --prefix=/usr \
                --exec-prefix=/usr \
                --bindir=/usr/bin \
@@ -192,6 +219,7 @@ define Build/Configure/Default
                --infodir=/usr/info \
                $(DISABLE_NLS) \
                $(1); \
+               true; \
        )
 endef
 
@@ -206,20 +234,27 @@ define Build/Compile/Default
                PREFIX="$$(IDIR_$(1))" \
                EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
                ARCH="$(ARCH)" \
-               DESTDIR="$$(IDIR_$(1))"
+               DESTDIR="$$(IDIR_$(1))" \
+               $(1);
 endef
 
 define Build/Compile
-  $(call Build/Compile/Default)
+  $(call Build/Compile/Default,)
+endef
+
+define Build/InstallDev
 endef
 
 define Build/Clean
        $(MAKE) clean
 endef
 
+define Build/UninstallDev
+endef
+
 ifneq ($(DUMP),)
-  dumpinfo:
-       $(DUMPINFO)
+  dumpinfo: FORCE
+       @$(DUMPINFO)
 else
                
   $(PACKAGE_DIR):
@@ -229,7 +264,7 @@ else
   prepare: $(PKG_BUILD_DIR)/.prepared
   configure: $(PKG_BUILD_DIR)/.configured
 
-  compile-targets:
+  compile-targets: $(PKG_BUILD_DIR)/.dev-installed
   compile: compile-targets
 
   install-targets:
@@ -240,6 +275,3 @@ else
        @$(MAKE) clean-targets
        rm -rf $(PKG_BUILD_DIR)
 endif
-
-.PHONY: FORCE
-FORCE: