cleanup; change base-files build directory
[openwrt/staging/dedeckeh.git] / openwrt / package / rules.mk
index e8417c3a5f4af9a3d74f2cb466c9b0cb8d63fbed..26b41969d9df57ec360a4c3f5baab6b1aad64339 100644 (file)
@@ -29,8 +29,13 @@ define Build/DefaultTargets
        $(call Build/Compile)
        touch $$@
     
+  $(PKG_BUILD_DIR)/.dev-installed: $(PKG_BUILD_DIR)/.built
+       $(call Build/InstallDev)
+       touch $$@
+    
   package-clean: FORCE
        $(call Build/Clean)
+       $(call Build/UninstallDev)
 
   package-rebuild: FORCE
        @-rm $(PKG_BUILD_DIR)/.built
@@ -103,6 +108,7 @@ define BuildPackage
   DUMPINFO += \
        echo "Version: $(VERSION)"; \
        echo "Depends: $$(IDEPEND_$(1))"; \
+       echo "Build-Depends: $(PKG_BUILDDEP)"; \
        echo "Category: $(CATEGORY)"; \
        echo "Title: $(TITLE)"; \
        echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n,g';
@@ -116,11 +122,24 @@ define BuildPackage
   DUMPINFO += \
        echo "@@";
 
+  ifneq ($(CONFIG),)
+    DUMPINFO += \
+       echo "Config: $(CONFIG)" | sed -e 's,\\,\n,g'; \
+       echo "@@";
+  endif
+
   $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
        mkdir -p $$(IDIR_$(1))/CONTROL
        echo "Package: $(1)" > $$(IDIR_$(1))/CONTROL/control
        echo "Version: $(VERSION)" >> $$(IDIR_$(1))/CONTROL/control
-       echo "Depends: $$(IDEPEND_$(1))" >> $$(IDIR_$(1))/CONTROL/control
+       ( \
+               DEPENDS=; \
+               for depend in $$(IDEPEND_$(1)); do \
+                       [ "$$$${depend%%%%%%%%[A-Za-z]*}" = "@" ] && continue; \
+                       DEPENDS=$$$${DEPENDS:+$$$$DEPENDS, }$$$${depend##+}; \
+               done; \
+               echo "Depends: $$$$DEPENDS" >> $$(IDIR_$(1))/CONTROL/control; \
+       )
        echo "Source: $(SOURCE)" >> $$(IDIR_$(1))/CONTROL/control
        echo "Section: $(SECTION)" >> $$(IDIR_$(1))/CONTROL/control
        echo "Priority: $(PRIORITY)" >> $$(IDIR_$(1))/CONTROL/control
@@ -135,6 +154,9 @@ define BuildPackage
   $$(IPKG_$(1)): $$(IDIR_$(1))/CONTROL/control $(PKG_BUILD_DIR)/.built
        $(call Package/$(1)/install,$$(IDIR_$(1)))
        mkdir -p $(PACKAGE_DIR)
+       -find $$(IDIR_$(1)) -name CVS | xargs rm -rf
+       -find $$(IDIR_$(1)) -name .svn | xargs rm -rf
+       -find $$(IDIR_$(1)) -name '.#*' | xargs rm -f
        $(RSTRIP) $$(IDIR_$(1))
        $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
 
@@ -177,10 +199,14 @@ define Build/Configure/Default
        [ -x configure ] && \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                ./configure \
                --target=$(GNU_TARGET_NAME) \
                --host=$(GNU_TARGET_NAME) \
                --build=$(GNU_HOST_NAME) \
+               --program-prefix="" \
+               --program-suffix="" \
                --prefix=/usr \
                --exec-prefix=/usr \
                --bindir=/usr/bin \
@@ -216,13 +242,19 @@ define Build/Compile
   $(call Build/Compile/Default,)
 endef
 
+define Build/InstallDev
+endef
+
 define Build/Clean
        $(MAKE) clean
 endef
 
+define Build/UninstallDev
+endef
+
 ifneq ($(DUMP),)
   dumpinfo: FORCE
-       $(DUMPINFO)
+       @$(DUMPINFO)
 else
                
   $(PACKAGE_DIR):
@@ -232,7 +264,7 @@ else
   prepare: $(PKG_BUILD_DIR)/.prepared
   configure: $(PKG_BUILD_DIR)/.configured
 
-  compile-targets:
+  compile-targets: $(PKG_BUILD_DIR)/.dev-installed
   compile: compile-targets
 
   install-targets: