revert .prepared handling
[openwrt/staging/dedeckeh.git] / openwrt / package / rules.mk
index 4faf9ffcd3663ff9ee1ad6d06ac3feb2165bb744..e5df61e1774d85ce27766432b1ba338805a4b2ff 100644 (file)
 ifneq ($(DUMP),)
-all: dumpinfo
+  all: dumpinfo
 else
-all: compile
+  all: compile
 endif
 
 define Build/DefaultTargets
-$(PKG_BUILD_DIR)/.prepared:
-       rm -rf $(PKG_BUILD_DIR)
-       mkdir -p $(PKG_BUILD_DIR)
+
+  ifeq ($(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) .),.)
+    $(PKG_BUILD_DIR)/.prepared: package-clean
+  endif
+
+  $(PKG_BUILD_DIR)/.prepared: $(DL_DIR)/$(PKG_SOURCE)
+       @-rm -rf $(PKG_BUILD_DIR)
+       @mkdir -p $(PKG_BUILD_DIR)
        $(call Build/Prepare)
        touch $$@
 
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+  $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
        $(call Build/Configure)
        touch $$@
 
-ifeq ($(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) .),.)
-$(PKG_BUILD_DIR)/.prepared: clean
-endif
-
-$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+  built: FORCE $(PKG_BUILD_DIR)/.configured
+    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $(IPKG_$(1)) $(PKG_BUILD_DIR)),$(IPKG_$(1)))
        $(call Build/Compile)
-       touch $$@
+    endif
 
-package-clean:
+  package-clean: FORCE
        $(call Build/Clean)
-       rm -f $(PKG_BUILD_DIR)/.built
-
-package-recompile:
-       rm -f $(PKG_BUILD_DIR)/.built
-
-.PHONY: package-clean package-recompile
 
-define Build/DefaultTargets
-endef
+  define Build/DefaultTargets
+  endef
 endef
 
 define Package/Default
-CONFIGFILE:=
-SECTION:=opt
-CATEGORY:=Extra packages
-DEPENDS:=
-MAINTAINER:=OpenWrt Developers Team <openwrt-devel@openwrt.org>
-SOURCE:=$(patsubst $(TOPDIR)/%,%,${shell pwd})
-VERSION:=$(PKG_VERSION)-$(PKG_RELEASE)
-PKGARCH:=$(ARCH)
-PRIORITY:=optional
-DEFAULT:=
-MENU:=
-TITLE:=
-DESCRIPTION:=
+  CONFIGFILE:=
+  SECTION:=opt
+  CATEGORY:=Extra packages
+  DEPENDS:=
+  MAINTAINER:=OpenWrt Developers Team <openwrt-devel@openwrt.org>
+  SOURCE:=$(patsubst $(TOPDIR)/%,%,${shell pwd})
+  VERSION:=$(PKG_VERSION)-$(PKG_RELEASE)
+  PKGARCH:=$(ARCH)
+  PRIORITY:=optional
+  DEFAULT:=
+  MENU:=
+  TITLE:=
+  DESCRIPTION:=
 endef
 
 define BuildPackage
-$(eval $(call Package/Default))
-$(eval $(call Package/$(1)))
+  $(eval $(call Package/Default))
+  $(eval $(call Package/$(1)))
 
-ifeq ($(TITLE),)
-$$(error Package $(1) has no TITLE)
-endif
-ifeq ($(CATEGORY),)
-$$(error Package $(1) has no CATEGORY)
-endif
-ifeq ($(PRIORITY),)
-$$(error Package $(1) has no PRIORITY)
-endif
-ifeq ($(VERSION),)
-$$(error Package $(1) has no VERSION)
-endif
-ifeq ($(PKGARCH),)
-PKGARCH:=$(ARCH)
-endif
-$(eval 
-ifeq ($(DESCRIPTION),)
-DESCRIPTION:=$(TITLE)
-endif
-)
+  $(foreach FIELD, TITLE CATEGORY PRIORITY VERSION,
+    ifeq ($($(FIELD)),)
+      $$(error Package/$(1) is missing the $(FIELD) field)
+    endif
+  )
 
-IPKG_$(1):=$(PACKAGE_DIR)/$(1)_$(VERSION)_$(PKGARCH).ipk
-IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(1)
-INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
+  ifeq ($(PKGARCH),)
+    PKGARCH:=$(ARCH)
+  endif
 
-ifneq ($(CONFIG_PACKAGE_$(1)),)
-COMPILE_$(1):=1
-endif
-ifneq ($(DEVELOPER),)
-COMPILE_$(1):=1
-endif
-ifeq ($(CONFIG_PACKAGE_$(1)),y)
-install-targets: $$(INFO_$(1))
-endif
+  ifeq ($(DESCRIPTION),)
+    $(eval DESCRIPTION:=$(TITLE))
+  endif
 
-ifneq ($$(COMPILE_$(1)),)
-ifeq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $$(IPKG_$(1)) $(PKG_BUILD_DIR)),$(PKG_BUILD_DIR))
-$(PKG_BUILD_DIR)/.built: package-recompile
-endif
+  IPKG_$(1):=$(PACKAGE_DIR)/$(1)_$(VERSION)_$(PKGARCH).ipk
+  IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(1)
+  INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
 
-compile-targets: $$(IPKG_$(1))
-endif
+  ifneq ($(CONFIG_PACKAGE_$(1))$(DEVELOPER),)
+    COMPILE_$(1):=1
+  endif
+
+  ifeq ($(CONFIG_PACKAGE_$(1)),y)
+    install-targets: $$(INFO_$(1))
+  endif
 
+  ifneq ($(COMPILE_$(1)),)
+    compile-targets: $(IPKG_$(1))
+  endif
 
-IDEPEND_$(1):=$$(strip $$(DEPENDS))
+  IDEPEND_$(1):=$$(strip $$(DEPENDS))
 
-DUMPINFO += \
+  DUMPINFO += \
        echo "Package: $(1)"; 
-ifneq ($(MENU),)
-DUMPINFO += \
+
+  ifneq ($(MENU),)
+    DUMPINFO += \
        echo "Menu: $(MENU)";
-endif
-ifneq ($(DEFAULT),)
-DUMPINFO += \
+  endif
+
+  ifneq ($(DEFAULT),)
+    DUMPINFO += \
        echo "Default: $(DEFAULT)";
-endif
-DUMPINFO += \
+  endif
+
+  DUMPINFO += \
        echo "Version: $(VERSION)"; \
        echo "Depends: $$(IDEPEND_$(1))"; \
        echo "Category: $(CATEGORY)"; \
        echo "Title: $(TITLE)"; \
        echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n,g';
-ifneq ($(URL),)
-DUMPINFO += \
+
+  ifneq ($(URL),)
+    DUMPINFO += \
        echo; \
        echo "$(URL)";
-endif
-DUMPINFO += \
-       echo "@@";
+  endif
 
+  DUMPINFO += \
+       echo "@@";
 
-$$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
+  $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
        mkdir -p $$(IDIR_$(1))/CONTROL
        echo "Package: $(1)" > $$(IDIR_$(1))/CONTROL/control
        echo "Version: $(VERSION)" >> $$(IDIR_$(1))/CONTROL/control
@@ -143,52 +129,51 @@ $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
                [ -f ./ipkg/$(1).$$$$file ] && cp ./ipkg/$(1).$$$$file $$(IDIR_$(1))/CONTROL/$$$$file || true; \
        done
 
-$$(IPKG_$(1)): $$(IDIR_$(1))/CONTROL/control $(PKG_BUILD_DIR)/.built
+  $$(IPKG_$(1)): $$(IDIR_$(1))/CONTROL/control built
        $(call Package/$(1)/install,$$(IDIR_$(1)))
        mkdir -p $(PACKAGE_DIR)
+       $(RSTRIP) $$(IDIR_$(1))
        $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
 
-$$(INFO_$(1)): $$(IPKG_$(1))
+  $$(INFO_$(1)): $$(IPKG_$(1))
        $(IPKG) install $$(IPKG_$(1))
 
-$(1)-clean:
+  $(1)-clean:
        rm -f $(PACKAGE_DIR)/$(1)_*
-clean: $(1)-clean
 
-ifneq ($(__DEFAULT_TARGETS),1)
-$(eval $(call Build/DefaultTargets))
-endif
+  clean: $(1)-clean
+
+  ifneq ($(__DEFAULT_TARGETS),1)
+    $$(eval $$(call Build/DefaultTargets,$(1)))
+  endif
 
 endef
 
 ifneq ($(strip $(PKG_SOURCE)),)
-$(DL_DIR)/$(PKG_SOURCE):
-       @$(CMD_TRACE) "downloading... "
-       $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(PKG_SOURCE)" "$(PKG_MD5SUM)" $(PKG_SOURCE_URL) $(MAKE_TRACE) 
-       
-$(PKG_BUILD_DIR)/.prepared: $(DL_DIR)/$(PKG_SOURCE)
+  $(DL_DIR)/$(PKG_SOURCE):
+       $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(PKG_SOURCE)" "$(PKG_MD5SUM)" $(PKG_SOURCE_URL)
 endif
 
 ifneq ($(strip $(PKG_CAT)),)
-define Build/Prepare/Default
-       if [ "$(PKG_CAT)" = "unzip" ]; then \
+  define Build/Prepare/Default
+       @if [ "$(PKG_CAT)" = "unzip" ]; then \
                unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE) ; \
        else \
                $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) - ; \
        fi                                                
-       if [ -d ./patches ]; then \
+       @if [ -d ./patches ]; then \
                $(PATCH) $(PKG_BUILD_DIR) ./patches ; \
        fi
-endef
+  endef
 endif
 
 define Build/Prepare
-$(call Build/Prepare/Default)
+  $(call Build/Prepare/Default)
 endef
 
 define Build/Configure/Default
-# TODO: add configurable default command
-       (cd $(PKG_BUILD_DIR); \
+       @(cd $(PKG_BUILD_DIR); \
+       [ -x configure ] && \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
                ./configure \
@@ -211,14 +196,21 @@ define Build/Configure/Default
 endef
 
 define Build/Configure
+  $(call Build/Configure/Default,)
 endef
 
 define Build/Compile/Default
-# TODO: add configurable default command
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC=$(TARGET_CC) \
+               CROSS="$(TARGET_CROSS)" \
+               PREFIX="$$(IDIR_$(1))" \
+               EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+               ARCH="$(ARCH)" \
+               DESTDIR="$$(IDIR_$(1))"
 endef
 
 define Build/Compile
-$(call Build/Compile/Default)
+  $(call Build/Compile/Default)
 endef
 
 define Build/Clean
@@ -226,45 +218,28 @@ define Build/Clean
 endef
 
 ifneq ($(DUMP),)
-dumpinfo:
+  dumpinfo:
        $(DUMPINFO)
 else
-
-source: $(DL_DIR)/$(PKG_SOURCE)
-prepare: source
-       @[ -f $(PKG_BUILD_DIR)/.prepared ] || { \
-               $(CMD_TRACE) "preparing... "; \
-               $(MAKE) $(PKG_BUILD_DIR)/.prepared $(MAKE_TRACE); \
-       }
-
-configure: prepare
-       @[ -f $(PKG_BUILD_DIR)/.configured ] || { \
-               $(CMD_TRACE) "configuring... "; \
-               $(MAKE) $(PKG_BUILD_DIR)/.configured $(MAKE_TRACE); \
-       }
-
-compile-targets:
-compile: configure
-       @$(CMD_TRACE) "compiling... " 
-       @$(MAKE) compile-targets $(MAKE_TRACE)
-
-install-targets:
-install:
-       @$(CMD_TRACE) "installing... "
-       @$(MAKE) install-targets $(MAKE_TRACE)
-
-rebuild:
-       $(CMD_TRACE) "rebuilding... "
-       $(MAKE) package-clean compile $(MAKE_TRACE)
-
-$(PACKAGE_DIR):
+               
+  $(PACKAGE_DIR):
        mkdir -p $@
 
-clean-targets:
-clean: 
-       @$(CMD_TRACE) "cleaning... " 
-       @$(MAKE) clean-targets $(MAKE_TRACE)
+  source: $(DL_DIR)/$(PKG_SOURCE)
+  prepare: $(PKG_BUILD_DIR)/.prepared
+  configure: $(PKG_BUILD_DIR)/.configured
+
+  compile-targets:
+  compile: compile-targets
+
+  install-targets:
+  install: install-targets
+
+  clean-targets:
+  clean: FORCE
+       @$(MAKE) clean-targets
        rm -rf $(PKG_BUILD_DIR)
 endif
 
-.PHONY: all source prepare compile install clean rebuild dumpinfo compile-targets install-targets clean-targets
+.PHONY: FORCE
+FORCE: