add preliminary support for the XScale port, generic endianness indication
[openwrt/svn-archive/archive.git] / openwrt / target / linux / generic-2.6 / patches / 005-gcc4_fix.patch
index 91da40ac37dda5632e83b17511cf2e53db9338cb..21d09b6f070b25911e53414b952d5965d51f3dec 100644 (file)
@@ -183,3 +183,15 @@ diff -Nur linux-2.6.15.1/lib/Makefile linux-2.6.15.1-openwrt/lib/Makefile
  
  obj-y += sort.o parser.o halfmd4.o
  
+diff -Nur linux-2.6.15.1/include/asm-arm/libgcc.h linux-2.6.15.1-openwrt/include/asm-arm/libgcc.h
+--- linux-2.6.15.1/include/asm-arm/libgcc.h    1970-01-01 01:00:00.000000000 +0100
++++ linux-2.6.15.1-openwrt/include/asm-arm/libgcc.h    2006-04-12 23:01:18.000000000 +0200
+@@ -0,0 +1,8 @@
++#ifndef __ASM_LIBGCC_H
++#define __ASM_LIBGCC_H
++
++#undef ARCH_NEEDS_ashldi3
++#undef ARCH_NEEDS_ashrdi3
++#undef ARCH_NEEDS_lshrdi3
++
++#endif /* __ASM_LIBGCC_H */