move old kamikaze out of trunk - will put buildroot-ng in there as soon as all the...
[openwrt/openwrt.git] / openwrt / target / linux / image / Makefile
diff --git a/openwrt/target/linux/image/Makefile b/openwrt/target/linux/image/Makefile
deleted file mode 100644 (file)
index e64efbf..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
-
-ifeq ($(BR2_TARGET_ROOTFS_JFFS2),y)
-include ./jffs2.mk
-endif
-
-ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS_LZMA),y)
-include ./squashfs.mk
-endif
-
-ifeq ($(BR2_TARGET_ROOTFS_TGZ),y)
-include ./tgz.mk
-endif
-
-prepare:
-       $(MAKE) prepare-targets $(MAKE_TRACE)
-compile:
-       $(MAKE) compile-targets $(MAKE_TRACE)
-install:
-       $(MAKE) install-targets $(MAKE_TRACE)
-
-.PHONY: prepare compile install
-
-$(BOARD)-compile:
-       @$(TRACE) target/linux/image/$(BOARD)-prepare
-       $(MAKE) -C $(BOARD) prepare
-       @$(TRACE) target/linux/image/$(BOARD)-compile
-       $(MAKE) -C $(BOARD) compile
-
-install-ib:
-       @$(TRACE) target/linux/image/$(BOARD)-install-ib
-       -$(MAKE) -C $(BOARD) IB_DIR="$(IB_DIR)" install-ib
-       mkdir -p $(IB_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD)
-       $(CP) $(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)/kernel[-_]*.ipk $(IB_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD)/   
-
-install-prepare:
-       find $(KDIR)/root -type f -not -perm +0100 | xargs chmod 0644
-       find $(KDIR)/root -type f -perm +0100 | xargs chmod 0755
-       find $(KDIR)/root -type d | xargs chmod 0755
-       mkdir -p $(KDIR)/root/tmp
-       chmod 0777 $(KDIR)/root/tmp
-
-rebuild: clean prepare compile install
-clean:
-       $(MAKE) clean-targets $(MAKE_TRACE)