add some changes from whiterussian to head
[openwrt/staging/mkresin.git] / openwrt / target / linux / image / squashfs.mk
index 917a69ab8a1bbc5f652b83ce687b0b31db1b0f3c..70a85b99ee7445329e5f401c46b9f7707fda0e2c 100644 (file)
@@ -10,7 +10,7 @@ squashfs-clean:
 
 $(KDIR)/root.squashfs:
        @mkdir -p $(KDIR)/root/jffs
-       $(STAGING_DIR)/bin/mksquashfs-lzma $(KDIR)/root $@ -noappend -root-owned -le
+       $(STAGING_DIR)/bin/mksquashfs-lzma $(KDIR)/root $@ -nopad -noappend -root-owned -le
 
 squashfs-install: $(KDIR)/root.squashfs
        $(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="squashfs"