6in4, 6to4: further simplify protocol backends - use new default route dependencies...
[openwrt/openwrt.git] / package / 6to4 / Makefile
index 45639646cc6325225fe73adaf2b2be61794b4530..740697f75e0cdb160b5bfe3644427e4c38d0aac7 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010-2011 OpenWrt.org
+# Copyright (C) 2010-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6to4
-PKG_VERSION:=7
+PKG_VERSION:=9
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -16,7 +16,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/6to4
   SECTION:=ipv6
   CATEGORY:=IPv6
-  DEPENDS:=+ip +kmod-ipv6 +kmod-sit
+  DEPENDS:=+kmod-ipv6 +kmod-sit
   TITLE:=IPv6-to-IPv4 configuration support
   MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
   PKGARCH:=all
@@ -34,20 +34,9 @@ endef
 define Build/Configure
 endef
 
-ifneq ($(CONFIG_PACKAGE_netifd),)
-  define Package/6to4/install
+define Package/6to4/install
        $(INSTALL_DIR) $(1)/lib/netifd/proto
        $(INSTALL_BIN) ./files/6to4.sh $(1)/lib/netifd/proto/6to4.sh
-       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
-       $(INSTALL_DATA) ./files/6to4.hotplug $(1)/etc/hotplug.d/iface/91-6to4
-  endef
-else
-  define Package/6to4/install
-       $(INSTALL_DIR) $(1)/lib/network
-       $(INSTALL_DATA) ./files.old/6to4.sh $(1)/lib/network/6to4.sh
-       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
-       $(INSTALL_DATA) ./files.old/6to4.hotplug $(1)/etc/hotplug.d/iface/91-6to4
-  endef
-endif
+endef
 
 $(eval $(call BuildPackage,6to4))