upgrade acx and acx-mac80211, removed two patches now unneeded
[openwrt/staging/florian.git] / package / acx / Makefile
index a0e087aec597638255929c98b75a297adea55188..2a1cbb32f15807f04821889df4aa073f173af9f2 100644 (file)
@@ -10,12 +10,12 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=acx
-PKG_VERSION:=20070610
+PKG_VERSION:=20071003
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@openwrt/
-PKG_MD5SUM:=ce36d3d00f87a331d3dee6d5359d4499
+PKG_SOURCE_URL:=@SF/acx100
+PKG_MD5SUM:=09cbaa558e1850d4996e7083d8b7bb93
 
 PKG_FW_NAME:=tiacx111c16
 PKG_FW_URL:=http://teknoraver.campuslife.it/software/acx-mac80211/
@@ -28,9 +28,10 @@ PKG_UNPACK:= \
 
 include $(INCLUDE_DIR)/package.mk
 
+# XXX: remove @!TARGET_* later when we have PCI support properly detected on all targets
 define KernelPackage/acx
   TITLE:=Driver for TI ACX1xx chipset
-  DEPENDS:=@LINUX_2_6 @!TARGET_avr32 +wireless-tools
+  DEPENDS:=@LINUX_2_6 +wireless-tools @!TARGET_atheros @!TARGET_avr32
   URL:=http://acx100.sourceforge.net/
   SUBMENU:=Wireless Drivers
   FILES:= $(PKG_BUILD_DIR)/acx.$(LINUX_KMOD_SUFFIX)
@@ -46,7 +47,6 @@ $(STAMP_BUILT): $(DL_DIR)/$(PKG_FW_NAME)
 $(DL_DIR)/$(PKG_FW_NAME):
        $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(PKG_FW_NAME)" "$(PKG_FW_MD5SUM)" $(PKG_FW_URL)
 
-
 define Build/Compile
        $(MAKE) -C $(LINUX_DIR) \
                SUBDIRS="$(PKG_BUILD_DIR)" \