don't build acx* kernel modules on UML
[openwrt/staging/florian.git] / package / acx-mac80211 / Makefile
index da8deee9f359b7f407fa5f5882a615ae05a452c0..4c96cdf4ab2bb7c6380a9a533b45028bedbe8e5a 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -31,7 +31,7 @@ include $(INCLUDE_DIR)/package.mk
 define KernelPackage/acx-mac80211
   SUBMENU:=Wireless Drivers
   TITLE:=ACX111 Mac80211 driver
-  DEPENDS:=+kmod-mac80211 @!TARGET_atheros
+  DEPENDS:=+kmod-mac80211 @!TARGET_atheros @!TARGET_uml @BROKEN
   FILES:=$(PKG_BUILD_DIR)/acx-mac80211.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,acx-mac80211)
 endef