remove obsolete kernel dependencies and version checks
[openwrt/staging/florian.git] / package / acx-mac80211 / Makefile
index ad498824ea984178effb209765dbc7750835e918..fb2216ff0dace30bde4206b5c25853d5412b987e 100644 (file)
@@ -4,37 +4,27 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=acx-mac80211
-PKG_REV:=11edba2
-PKG_VERSION:=20080805
+PKG_REV:=02c4f99b
+PKG_VERSION:=20100514
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=git://gitorious.org/acx-mac80211/mainline.git
+PKG_SOURCE_URL:=git://gitorious.org/~oli1417/acx-mac80211/oli1417-clone.git
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_VERSION:=$(PKG_REV)
 
-PKG_FW_C16_NAME:=tiacx111c16
-PKG_FW_C16_URL:=http://teknoraver.net/software/acx-mac80211/
-#PKG_FW_C16_MD5SUM:=fcd07de4b25e1d2aaf3b78b27c5b7ee9   #version 1.2.1.34
-PKG_FW_C16_MD5SUM:=7026826460376f6b174f9225bd7781b9    #version 2.3.1.31
-
-PKG_FW_C19_NAME:=tiacx111c19
-PKG_FW_C19_URL:=http://ipkg.k1k2.de/files/
-PKG_FW_C19_MD5SUM:=a1fa9681e297b4e36e257090fc12265a
-
 include $(INCLUDE_DIR)/package.mk
 
 define KernelPackage/acx-mac80211
   SUBMENU:=Wireless Drivers
   TITLE:=ACX111 Mac80211 driver
-  DEPENDS:=@LINUX_2_6 @PCI_SUPPORT||TARGET_ar7 +kmod-mac80211 @BROKEN
+  DEPENDS:=@PCI_SUPPORT||TARGET_ar7 +kmod-mac80211
   FILES:=$(PKG_BUILD_DIR)/acx-mac80211.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,acx-mac80211)
 endef
@@ -43,13 +33,24 @@ define KernelPackage/acx-mac80211/description
        Driver for acx111 cards (Mac80211 version)
 endef
 
-$(STAMP_BUILT): $(DL_DIR)/$(PKG_FW_C16_NAME) $(DL_DIR)/$(PKG_FW_C19_NAME)
 
-$(DL_DIR)/$(PKG_FW_C16_NAME):
-       $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(PKG_FW_C16_NAME)" "$(PKG_FW_C16_MD5SUM)" $(PKG_FW_C16_URL)
+C16_FW:=tiacx111c16
+C19_FW:=tiacx111c19
+
+define Download/tiacx111c16
+  FILE:=$(C16_FW)
+  URL:=http://teknoraver.net/software/acx-mac80211/
+  MD5SUM:=7026826460376f6b174f9225bd7781b9
+endef
+$(eval $(call Download,tiacx111c16))
+
+define Download/tiacx111c19
+  FILE:=$(C19_FW)
+  URL:=http://ipkg.k1k2.de/files/
+  MD5SUM:=a1fa9681e297b4e36e257090fc12265a
+endef
+$(eval $(call Download,tiacx111c19))
 
-$(DL_DIR)/$(PKG_FW_C19_NAME):
-       $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(PKG_FW_C19_NAME)" "$(PKG_FW_C19_MD5SUM)" $(PKG_FW_C19_URL)
 
 PKG_EXTRA_KCONFIG:= \
        CONFIG_ACX_MAC80211=m \
@@ -65,8 +66,9 @@ define Build/Compile
                CROSS_COMPILE="$(TARGET_CROSS)" \
                SUBDIRS="$(PKG_BUILD_DIR)" \
                $(PKG_EXTRA_KCONFIG) \
-               EXTRA_CFLAGS="$(PKG_EXTRA_CFLAGS)" \
+               EXTRA_CFLAGS="$(PKG_EXTRA_CFLAGS) -DCONFIG_ACX_MAC80211_VERSION=\"KERNEL_VERSION(2,6,34)\"" \
                LINUXINCLUDE="-I$(STAGING_DIR)/usr/include/mac80211 -I$(LINUX_DIR)/include \
+                       -Iarch/$(LINUX_KARCH)/include \
                        -include linux/autoconf.h" \
                V="$(V)" \
                modules
@@ -77,8 +79,8 @@ endef
 
 define KernelPackage/acx-mac80211/install
        $(INSTALL_DIR) $(1)/lib/firmware
-       $(INSTALL_DATA) $(DL_DIR)/$(PKG_FW_C16_NAME) $(1)/lib/firmware/
-       $(INSTALL_DATA) $(DL_DIR)/$(PKG_FW_C19_NAME) $(1)/lib/firmware/
+       $(INSTALL_DATA) $(DL_DIR)/$(C16_FW) $(1)/lib/firmware/
+       $(INSTALL_DATA) $(DL_DIR)/$(C19_FW) $(1)/lib/firmware/
 endef
 
 $(eval $(call KernelPackage,acx-mac80211))