base-files: merge /etc/passwd et al at sysupgrade config restore
[openwrt/openwrt.git] / package / base-files / Makefile
index f0085e56905c5854d13a0dd7f6a063b0ebdf5732..84b2f2d5ec292fe34631f2005d4b3e2a0322d215 100644 (file)
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=217
+PKG_RELEASE:=233
 PKG_FLAGS:=nonshared
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
@@ -37,21 +37,12 @@ endif
 define Package/base-files
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+netifd +libc +procd +jsonfilter +SIGNED_PACKAGES:usign +SIGNED_PACKAGES:openwrt-keyring +NAND_SUPPORT:ubi-utils +fstools +fwtool
+  DEPENDS:=+netifd +libc +jsonfilter +SIGNED_PACKAGES:usign +SIGNED_PACKAGES:openwrt-keyring +NAND_SUPPORT:ubi-utils +fstools +fwtool
   TITLE:=Base filesystem for OpenWrt
   URL:=http://openwrt.org/
   VERSION:=$(PKG_RELEASE)-$(REVISION)
 endef
 
-define Package/urandom-seed
-  SECTION:=base
-  CATEGORY:=Base system
-  DEPENDS:=+libc +ubox-getrandom
-  TITLE:=/etc/urandom.seed handling for OpenWrt
-  URL:=http://openwrt.org/
-  VERSION:=$(PKG_RELEASE)-$(REVISION)
-endef
-
 define Package/base-files/conffiles
 /etc/config/
 /etc/config/network
@@ -118,12 +109,14 @@ ifdef CONFIG_SIGNED_PACKAGES
 
   endef
 
+ifndef CONFIG_BUILDBOT
   define Package/base-files/install-key
        mkdir -p $(1)/etc/opkg/keys
        $(CP) $(BUILD_KEY).pub $(1)/etc/opkg/keys/`$(STAGING_DIR_HOST)/bin/usign -F -p $(BUILD_KEY).pub`
 
   endef
 endif
+endif
 
 ifeq ($(CONFIG_NAND_SUPPORT),)
   define Package/base-files/nand-support