base-files: fix UCI config parsing and callback handling
[openwrt/staging/wigyori.git] / package / base-files / Makefile
index 37f0e1e2fd4862a77e90e079b01d4816fefd028f..89ee0be3154ef6a6f3d1351a811babf796b035ea 100644 (file)
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=186
+PKG_RELEASE:=191
 PKG_FLAGS:=nonshared
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
@@ -39,7 +39,7 @@ endif
 define Package/base-files
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+netifd +libc +procd +jsonfilter +SIGNED_PACKAGES:usign +SIGNED_PACKAGES:lede-keyring +NAND_SUPPORT:ubi-utils +fstools +fwtool
+  DEPENDS:=+netifd +libc +procd +jsonfilter +SIGNED_PACKAGES:usign +SIGNED_PACKAGES:openwrt-keyring +NAND_SUPPORT:ubi-utils +fstools +fwtool
   TITLE:=Base filesystem for OpenWrt
   URL:=http://openwrt.org/
   VERSION:=$(PKG_RELEASE)-$(REVISION)
@@ -65,8 +65,6 @@ define Package/base-files/conffiles
 /etc/shadow
 /etc/shells
 /etc/sysctl.conf
-/etc/sysctl.d/
-/etc/sysctl.d/local.conf
 /etc/sysupgrade.conf
 $(call $(TARGET)/conffiles)
 endef