base-files: read all 3 bytes in get_magic_vfat() at once
[openwrt/staging/mkresin.git] / package / base-files / Makefile
index b546eb7e0bc0a1de3dafc35a6f2172533ac556f2..f18f221129e4edad4ce390d349fcce40dbd8bf38 100644 (file)
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=236
+PKG_RELEASE:=246
 PKG_FLAGS:=nonshared
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
@@ -202,6 +202,9 @@ define Package/base-files/install
                $(VERSION_SED_SCRIPT) $(1)/etc/opkg/distfeeds.conf)
        $(if $(CONFIG_IPK_FILES_CHECKSUMS),, \
                rm -f $(1)/sbin/pkg_check)
+
+       $(if $(CONFIG_TARGET_PREINIT_DISABLE_FAILSAFE), \
+               rm -f $(1)/etc/banner.failsafe,)
 endef
 
 ifneq ($(DUMP),1)