ixp4xx: fix imagebuilder
[openwrt/svn-archive/archive.git] / package / boot / apex / Makefile
index 64315a1ae87e82cef49c84253163fd7d7343b533..f154f9606e691687dc64187561e5e77867540dd6 100644 (file)
@@ -6,6 +6,7 @@
 #
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=apex
 PKG_VERSION:=1.6.9
@@ -16,9 +17,6 @@ PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
 PKG_MD5SUM:=9606cf2e3fd2c9a86fe0b61388509a30
 PKG_TARGETS:=bin
 
-PKG_LICENSE:=GPL-2.0+
-PKG_LICENSE_FILES:=COPYING
-
 include $(INCLUDE_DIR)/package.mk
 
 export GCC_HONOUR_COPTS=s
@@ -57,4 +55,8 @@ define Package/apex/install
        $(CP) $(PKG_BUILD_DIR)/out/*.bin $(1)/
 endef
 
+define Build/InstallDev
+       $(CP) $(PKG_BUILD_DIR)/out/*.bin $(KERNEL_BUILD_DIR)
+endef
+
 $(eval $(call BuildPackage,apex))