Add more license tags with SPDX identifiers
[openwrt/staging/yousong.git] / package / boot / uboot-kirkwood / Makefile
index 328da81cfff14c91e0e35e662d6ac2c8bcd65fe9..2f4a1bbbfe8977ce9a05cc9a44796699100d33a9 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010-2013 OpenWrt.org
+# Copyright (C) 2010-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=u-boot
-PKG_VERSION:=2013.10
+PKG_VERSION:=2014.07
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
@@ -16,9 +16,12 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
        http://mirror2.openwrt.org/sources \
        ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=a076a044b64371edc52f7e562b13f6b2
+PKG_MD5SUM:=36d4bad687edcafa396fee607e505d4e
 PKG_TARGETS:=bin
 
+PKG_LICENSE:=GPL-2.0 GPL-2.0+
+PKG_LICENSE_FILES:=Licenses/README
+
 PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -37,6 +40,10 @@ define uboot/dockstar_second_stage
   TITLE:=second stage U-Boot for Seagate DockStar
 endef
 
+define uboot/goflexhome
+  TITLE:=U-Boot for the Seagate GoFlexHome/GoFlexNet
+endef
+
 define uboot/ib62x0
   TITLE:=U-Boot for RaidSonic ICY BOX NAS6210 and NAS6220
 endef
@@ -57,15 +64,20 @@ define uboot/pogo_e02
   TITLE:=U-Boot for Cloud Engines Pogoplug E02
 endef
 
+define uboot/pogo_e02_second_stage
+  TITLE:=second stage U-Boot for Cloud Engines Pogoplug E02
+endef
+
 define uboot/sheevaplug
   TITLE:=U-Boot for SheevaPlug
 endef
 
 UBOOTS:= \
        dockstar dockstar_second_stage \
+       goflexhome \
        ib62x0 ib62x0_second_stage \
        iconnect iconnect_second_stage \
-       pogo_e02 \
+       pogo_e02 pogo_e02_second_stage \
        sheevaplug
 
 define Package/uboot/template