layerscape: use semantic versions for LSDK
[openwrt/openwrt.git] / package / boot / uboot-layerscape / Makefile
index 39dc6c76d1061b5db969df5259cd9e15494131d9..bd30a15ade96840761406e382c66020398ec542e 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uboot-layerscape
-PKG_VERSION:=lsdk-1806
-PKG_RELEASE:=1
+PKG_VERSION:=21.08
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://source.codeaurora.org/external/qoriq/qoriq-components/u-boot
-PKG_SOURCE_VERSION:=b3f98d438eefd1b355efdec0b50af5813ff8d0e1
-PKG_MIRROR_HASH:=59e35957055658e7fdefb16b92f954356985a8191942d93f254861c75c47b32b
+PKG_SOURCE_VERSION:=LSDK-21.08
+PKG_MIRROR_HASH:=874e871755ef84ebbf35cc247f0979ec18ed1946e4dca71006a83463b2899db1
 
 include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
@@ -27,64 +27,87 @@ define U-Boot/Default
   ENV_SIZE:=0x2000
 endef
 
-define U-Boot/ls1012ardb
+define U-Boot/fsl_ls1012a-frdm
+  NAME:=NXP LS1012AFRDM
+  UBOOT_CONFIG:=ls1012afrdm_tfa
+  ENV_SIZE:=0x40000
+endef
+
+define U-Boot/fsl_ls1012a-rdb
   NAME:=NXP LS1012ARDB
-  UBOOT_CONFIG:=ls1012ardb_qspi
+  UBOOT_CONFIG:=ls1012ardb_tfa
   ENV_SIZE:=0x40000
 endef
 
-define U-Boot/ls1012afrwy
+define U-Boot/fsl_ls1012a-frwy-sdboot
   NAME:=NXP LS1012AFRWY
-  UBOOT_CONFIG:=ls1012afrwy_qspi
+  UBOOT_CONFIG:=ls1012afrwy_tfa
   ENV_SIZE:=0x10000
 endef
 
-define U-Boot/ls1043ardb
+define U-Boot/fsl_ls1043a-rdb
   NAME:=NXP LS1043ARDB
-  ENV_SIZE:=0x20000
+  UBOOT_CONFIG:=ls1043ardb_tfa
 endef
 
-define U-Boot/ls1043ardb-sdboot
+define U-Boot/fsl_ls1043a-rdb-sdboot
   NAME:=NXP LS1043ARDB SD Card Boot
-  UBOOT_CONFIG:=ls1043ardb_sdcard
-  UBOOT_IMAGE:=u-boot-with-spl-pbl.bin
+  UBOOT_CONFIG:=ls1043ardb_tfa
 endef
 
-define U-Boot/ls1046ardb
+define U-Boot/fsl_ls1046a-frwy
+  NAME:=NXP LS1046AFRWY
+  UBOOT_CONFIG:=ls1046afrwy_tfa
+endef
+
+define U-Boot/fsl_ls1046a-frwy-sdboot
+  NAME:=NXP LS1046AFRWY SD Card Boot
+  UBOOT_CONFIG:=ls1046afrwy_tfa
+endef
+
+define U-Boot/fsl_ls1046a-rdb
   NAME:=NXP LS1046ARDB
-  UBOOT_CONFIG:=ls1046ardb_qspi
+  UBOOT_CONFIG:=ls1046ardb_tfa
 endef
 
-define U-Boot/ls1046ardb-sdboot
+define U-Boot/fsl_ls1046a-rdb-sdboot
   NAME:=NXP LS1046ARDB SD Card Boot
-  UBOOT_CONFIG:=ls1046ardb_sdcard
-  UBOOT_IMAGE:=u-boot-with-spl-pbl.bin
+  UBOOT_CONFIG:=ls1046ardb_tfa
 endef
 
-define U-Boot/ls1088ardb
+define U-Boot/fsl_ls1088a-rdb
   NAME:=NXP LS1088ARDB
-  UBOOT_CONFIG:=ls1088ardb_qspi
+  UBOOT_CONFIG:=ls1088ardb_tfa
 endef
 
-define U-Boot/ls1088ardb-sdboot
+define U-Boot/fsl_ls1088a-rdb-sdboot
   NAME:=NXP LS1088ARDB SD Card Boot
-  UBOOT_CONFIG:=ls1088ardb_sdcard_qspi
-  UBOOT_IMAGE:=u-boot-with-spl.bin
+  UBOOT_CONFIG:=ls1088ardb_tfa
 endef
 
-define U-Boot/ls2088ardb
+define U-Boot/fsl_ls2088a-rdb
   NAME:=NXP LS2088ARDB
-  UBOOT_CONFIG:=ls2080ardb
+  UBOOT_CONFIG:=ls2088ardb_tfa
 endef
 
-define U-Boot/ls1021atwr
+define U-Boot/fsl_lx2160a-rdb
+  NAME:=NXP LX2160ARDB
+  UBOOT_CONFIG:=lx2160ardb_tfa
+endef
+
+define U-Boot/fsl_lx2160a-rdb-sdboot
+  NAME:=NXP LX2160ARDB SD Card Boot
+  UBOOT_CONFIG:=lx2160ardb_tfa
+endef
+
+define U-Boot/fsl_ls1021a-twr
   NAME:=NXP LS1021ATWR
   BUILD_SUBTARGET:=armv7
   UBOOT_CONFIG:=ls1021atwr_nor
   ENV_SIZE:=0x20000
 endef
 
-define U-Boot/ls1021atwr-sdboot
+define U-Boot/fsl_ls1021a-twr-sdboot
   NAME:=NXP LS1021ATWR SD Card Boot
   BUILD_SUBTARGET:=armv7
   UBOOT_CONFIG:=ls1021atwr_sdcard_ifc
@@ -92,18 +115,32 @@ define U-Boot/ls1021atwr-sdboot
   ENV_SIZE:=0x20000
 endef
 
+define U-Boot/fsl_ls1021a-iot-sdboot
+  NAME:=NXP LS1021AIOT SD Card Boot
+  BUILD_SUBTARGET:=armv7
+  UBOOT_CONFIG:=ls1021aiot_sdcard
+  UBOOT_IMAGE:=u-boot-with-spl-pbl.bin
+  ENV_SIZE:=0x2000
+endef
+
 UBOOT_TARGETS := \
-  ls1012ardb \
-  ls1012afrwy \
-  ls1043ardb \
-  ls1043ardb-sdboot \
-  ls1046ardb \
-  ls1046ardb-sdboot \
-  ls1088ardb \
-  ls1088ardb-sdboot \
-  ls2088ardb \
-  ls1021atwr \
-  ls1021atwr-sdboot
+  fsl_ls1012a-frdm \
+  fsl_ls1012a-rdb \
+  fsl_ls1012a-frwy-sdboot \
+  fsl_ls1043a-rdb \
+  fsl_ls1043a-rdb-sdboot \
+  fsl_ls1046a-frwy \
+  fsl_ls1046a-frwy-sdboot \
+  fsl_ls1046a-rdb \
+  fsl_ls1046a-rdb-sdboot \
+  fsl_ls1088a-rdb \
+  fsl_ls1088a-rdb-sdboot \
+  fsl_ls2088a-rdb \
+  fsl_lx2160a-rdb \
+  fsl_lx2160a-rdb-sdboot \
+  fsl_ls1021a-twr \
+  fsl_ls1021a-twr-sdboot \
+  fsl_ls1021a-iot-sdboot
 
 define Build/InstallDev
        $(INSTALL_DIR) $(STAGING_DIR_IMAGE)