uboot-sunxi: Update to version 2018.11
[openwrt/staging/lynxis.git] / package / boot / uboot-sunxi / patches / 003-add-theobroma-a31-pangolin.patch
index 6501cca6d2a02e0050d766361012122a8a2408ba..93ded58c718f9dcba960c990f32e40f524d0dcfb 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm/dts/Makefile
 +++ b/arch/arm/dts/Makefile
-@@ -290,6 +290,7 @@ dtb-$(CONFIG_MACH_SUN6I) += \
+@@ -306,6 +306,7 @@ dtb-$(CONFIG_MACH_SUN6I) += \
        sun6i-a31-m9.dtb \
        sun6i-a31-mele-a1000g-quad.dtb \
        sun6i-a31-mixtile-loftq.dtb \
@@ -10,8 +10,8 @@
        sun6i-a31s-inet-q972.dtb \
 --- a/arch/arm/dts/sun6i-a31.dtsi
 +++ b/arch/arm/dts/sun6i-a31.dtsi
-@@ -679,6 +679,13 @@
-                               allwinner,pull = <SUN4I_PINCTRL_NO_PULL>;
+@@ -641,6 +641,13 @@
+                               function = "lcd0";
                        };
  
 +                      i2c3_pins_a: i2c3@0 {
@@ -22,7 +22,7 @@
 +                      };
 +
                        mmc0_pins_a: mmc0@0 {
-                               allwinner,pins = "PF0", "PF1", "PF2",
+                               pins = "PF0", "PF1", "PF2",
                                                 "PF3", "PF4", "PF5";
 --- /dev/null
 +++ b/arch/arm/dts/sun6i-a31-pangolin.dts
 +CONFIG_SUNXI_SPI=y
 --- a/arch/arm/mach-sunxi/Kconfig
 +++ b/arch/arm/mach-sunxi/Kconfig
-@@ -836,6 +836,14 @@ config VIDEO_LCD_PANEL_I2C_SCL
+@@ -872,6 +872,14 @@ config VIDEO_LCD_PANEL_I2C_SCL
        Set the SCL pin for the LCD i2c interface. This takes a string in the
        format understood by sunxi_name_to_gpio, e.g. PH1 for pin 1 of port H.