sunxi: add Orange Pi R1 support
[openwrt/staging/lynxis.git] / package / boot / uboot-sunxi / patches / 300-sunxi-add-device-tree-for-Orange-Pi-R1-board.patch
diff --git a/package/boot/uboot-sunxi/patches/300-sunxi-add-device-tree-for-Orange-Pi-R1-board.patch b/package/boot/uboot-sunxi/patches/300-sunxi-add-device-tree-for-Orange-Pi-R1-board.patch
new file mode 100644 (file)
index 0000000..65ae63c
--- /dev/null
@@ -0,0 +1,182 @@
+From 1f92596cc520f760589289059a5aa739366dd19c Mon Sep 17 00:00:00 2001
+From: Hauke Mehrtens <hauke@hauke-m.de>
+Date: Tue, 26 Sep 2017 22:16:59 +0200
+Subject: sunxi: add device tree for Orange Pi R1 board
+
+Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
+---
+ arch/arm/dts/Makefile                      |   1 +
+ arch/arm/dts/sun8i-h2-plus-orangepi-r1.dts | 157 +++++++++++++++++++++++++++++
+ 2 files changed, 158 insertions(+)
+ create mode 100644 arch/arm/dts/sun8i-h2-plus-orangepi-r1.dts
+
+--- a/arch/arm/dts/Makefile
++++ b/arch/arm/dts/Makefile
+@@ -310,6 +310,7 @@ dtb-$(CONFIG_MACH_SUN8I_A83T) += \
+       sun8i-a83t-cubietruck-plus.dtb \
+       sun8i-a83t-sinovoip-bpi-m3.dtb
+ dtb-$(CONFIG_MACH_SUN8I_H3) += \
++      sun8i-h2-plus-orangepi-r1.dtb \
+       sun8i-h2-plus-orangepi-zero.dtb \
+       sun8i-h3-bananapi-m2-plus.dtb \
+       sun8i-h3-orangepi-2.dtb \
+--- /dev/null
++++ b/arch/arm/dts/sun8i-h2-plus-orangepi-r1.dts
+@@ -0,0 +1,157 @@
++/*
++ * Copyright (C) 2017 Hauke Mehrtens <hauke@hauke-m.de>
++ *
++ * Based on sun8i-h2-plus-orangepi-zero.dts, which is:
++ *   Copyright (C) 2016 Icenowy Zheng <icenowy@aosc.xyz>
++ *
++ * Based on sun8i-h3-orangepi-one.dts, which is:
++ *   Copyright (C) 2016 Hans de Goede <hdegoede@redhat.com>
++ *
++ * This file is dual-licensed: you can use it either under the terms
++ * of the GPL or the X11 license, at your option. Note that this dual
++ * licensing only applies to this file, and not this project as a
++ * whole.
++ *
++ *  a) This file is free software; you can redistribute it and/or
++ *     modify it under the terms of the GNU General Public License as
++ *     published by the Free Software Foundation; either version 2 of the
++ *     License, or (at your option) any later version.
++ *
++ *     This file is distributed in the hope that it will be useful,
++ *     but WITHOUT ANY WARRANTY; without even the implied warranty of
++ *     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
++ *     GNU General Public License for more details.
++ *
++ * Or, alternatively,
++ *
++ *  b) Permission is hereby granted, free of charge, to any person
++ *     obtaining a copy of this software and associated documentation
++ *     files (the "Software"), to deal in the Software without
++ *     restriction, including without limitation the rights to use,
++ *     copy, modify, merge, publish, distribute, sublicense, and/or
++ *     sell copies of the Software, and to permit persons to whom the
++ *     Software is furnished to do so, subject to the following
++ *     conditions:
++ *
++ *     The above copyright notice and this permission notice shall be
++ *     included in all copies or substantial portions of the Software.
++ *
++ *     THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
++ *     EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
++ *     OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
++ *     NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
++ *     HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
++ *     WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
++ *     FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
++ *     OTHER DEALINGS IN THE SOFTWARE.
++ */
++
++/dts-v1/;
++#include "sun8i-h3.dtsi"
++#include "sunxi-common-regulators.dtsi"
++
++#include <dt-bindings/gpio/gpio.h>
++#include <dt-bindings/input/input.h>
++#include <dt-bindings/pinctrl/sun4i-a10.h>
++
++/ {
++      model = "Xunlong Orange Pi R1";
++      compatible = "xunlong,orangepi-r1", "allwinner,sun8i-h2-plus";
++
++      aliases {
++              serial0 = &uart0;
++              /* ethernet0 is the H3 emac, defined in sun8i-h3.dtsi */
++              ethernet1 = &xr819;
++      };
++
++      chosen {
++              stdout-path = "serial0:115200n8";
++      };
++
++      leds {
++              compatible = "gpio-leds";
++
++              pwr_led {
++                      label = "orangepi:green:pwr";
++                      gpios = <&r_pio 0 10 GPIO_ACTIVE_HIGH>;
++                      default-state = "on";
++              };
++
++              status_led {
++                      label = "orangepi:red:status";
++                      gpios = <&pio 0 17 GPIO_ACTIVE_HIGH>;
++              };
++      };
++
++      reg_vcc_wifi: reg_vcc_wifi {
++              compatible = "regulator-fixed";
++              regulator-min-microvolt = <3300000>;
++              regulator-max-microvolt = <3300000>;
++              regulator-name = "vcc-wifi";
++              enable-active-high;
++              gpio = <&pio 0 20 GPIO_ACTIVE_HIGH>;
++      };
++
++      wifi_pwrseq: wifi_pwrseq {
++              compatible = "mmc-pwrseq-simple";
++              reset-gpios = <&r_pio 0 7 GPIO_ACTIVE_LOW>;
++      };
++};
++
++&ehci1 {
++      status = "okay";
++};
++
++&emac {
++      phy = <&phy1>;
++      phy-mode = "mii";
++      allwinner,use-internal-phy;
++      allwinner,leds-active-low;
++      status = "okay";
++      phy1: ethernet-phy@1 {
++              reg = <1>;
++      };
++};
++
++&mmc0 {
++      pinctrl-names = "default";
++      pinctrl-0 = <&mmc0_pins_a>;
++      vmmc-supply = <&reg_vcc3v3>;
++      bus-width = <4>;
++      cd-gpios = <&pio 5 6 GPIO_ACTIVE_HIGH>; /* PF6 */
++      cd-inverted;
++      status = "okay";
++};
++
++&mmc1 {
++      pinctrl-names = "default";
++      pinctrl-0 = <&mmc1_pins_a>;
++      vmmc-supply = <&reg_vcc_wifi>;
++      mmc-pwrseq = <&wifi_pwrseq>;
++      bus-width = <4>;
++      non-removable;
++      status = "okay";
++
++      /*
++       * Explicitly define the sdio device, so that we can add an ethernet
++       * alias for it (which e.g. makes u-boot set a mac-address).
++       */
++      xr819: sdio_wifi@1 {
++              reg = <1>;
++      };
++};
++
++&ohci1 {
++      status = "okay";
++};
++
++&uart0 {
++      pinctrl-names = "default";
++      pinctrl-0 = <&uart0_pins_a>;
++      status = "okay";
++};
++
++&usbphy {
++      /* USB VBUS is always on */
++      status = "okay";
++};