uboot-sunxi: dts: Update orange Pi R1 integration
[openwrt/openwrt.git] / package / boot / uboot-sunxi / patches / 320-sunxi-Add-support-for-Orange-Pi-R1.patch
diff --git a/package/boot/uboot-sunxi/patches/320-sunxi-Add-support-for-Orange-Pi-R1.patch b/package/boot/uboot-sunxi/patches/320-sunxi-Add-support-for-Orange-Pi-R1.patch
new file mode 100644 (file)
index 0000000..af45982
--- /dev/null
@@ -0,0 +1,157 @@
+From 068fb0d5728c5ec93cb961718d59e7c718886edd Mon Sep 17 00:00:00 2001
+From: Hauke Mehrtens <hauke@hauke-m.de>
+Date: Tue, 26 Sep 2017 22:16:59 +0200
+Subject: sunxi: Add support for Orange Pi R1
+
+The device tree files are also submitted for inclusion into the Linux
+kernel.
+
+Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
+---
+ arch/arm/dts/Makefile                      |  1 +
+ arch/arm/dts/sun8i-h2-plus-orangepi-r1.dts | 77 ++++++++++++++++++++++++++++++
+ board/sunxi/MAINTAINERS                    |  5 ++
+ configs/orangepi_r1_defconfig              | 26 ++++++++++
+ 4 files changed, 109 insertions(+)
+ create mode 100644 arch/arm/dts/sun8i-h2-plus-orangepi-r1.dts
+ create mode 100644 configs/orangepi_r1_defconfig
+
+--- a/arch/arm/dts/Makefile
++++ b/arch/arm/dts/Makefile
+@@ -310,6 +310,7 @@ dtb-$(CONFIG_MACH_SUN8I_A83T) += \
+       sun8i-a83t-cubietruck-plus.dtb \
+       sun8i-a83t-sinovoip-bpi-m3.dtb
+ dtb-$(CONFIG_MACH_SUN8I_H3) += \
++      sun8i-h2-plus-orangepi-r1.dtb \
+       sun8i-h2-plus-orangepi-zero.dtb \
+       sun8i-h3-bananapi-m2-plus.dtb \
+       sun8i-h3-orangepi-2.dtb \
+--- /dev/null
++++ b/arch/arm/dts/sun8i-h2-plus-orangepi-r1.dts
+@@ -0,0 +1,91 @@
++/*
++ * Copyright (C) 2017 Icenowy Zheng <icenowy@aosc.xyz>
++ *
++ * This file is dual-licensed: you can use it either under the terms
++ * of the GPL or the X11 license, at your option. Note that this dual
++ * licensing only applies to this file, and not this project as a
++ * whole.
++ *
++ *  a) This file is free software; you can redistribute it and/or
++ *     modify it under the terms of the GNU General Public License as
++ *     published by the Free Software Foundation; either version 2 of the
++ *     License, or (at your option) any later version.
++ *
++ *     This file is distributed in the hope that it will be useful,
++ *     but WITHOUT ANY WARRANTY; without even the implied warranty of
++ *     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
++ *     GNU General Public License for more details.
++ *
++ * Or, alternatively,
++ *
++ *  b) Permission is hereby granted, free of charge, to any person
++ *     obtaining a copy of this software and associated documentation
++ *     files (the "Software"), to deal in the Software without
++ *     restriction, including without limitation the rights to use,
++ *     copy, modify, merge, publish, distribute, sublicense, and/or
++ *     sell copies of the Software, and to permit persons to whom the
++ *     Software is furnished to do so, subject to the following
++ *     conditions:
++ *
++ *     The above copyright notice and this permission notice shall be
++ *     included in all copies or substantial portions of the Software.
++ *
++ *     THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
++ *     EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
++ *     OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
++ *     NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
++ *     HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
++ *     WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
++ *     FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
++ *     OTHER DEALINGS IN THE SOFTWARE.
++ */
++
++/* Orange Pi R1 is based on Orange Pi Zero design */
++#include "sun8i-h2-plus-orangepi-zero.dts"
++
++/ {
++      model = "Xunlong Orange Pi R1";
++      compatible = "xunlong,orangepi-r1", "allwinner,sun8i-h2-plus";
++
++      /delete-node/ reg_vcc_wifi;
++
++      /*
++       * Ths pin of this regulator is the same with the Wi-Fi extra
++       * regulator on the original Zero. However it's used for USB
++       * Ethernet rather than the Wi-Fi now.
++       */
++      reg_vcc_usb_eth: reg-vcc-usb-ethernet {
++              compatible = "regulator-fixed";
++              regulator-min-microvolt = <5000000>;
++              regulator-max-microvolt = <5000000>;
++              regulator-name = "vcc-usb-ethernet";
++              enable-active-high;
++              gpio = <&pio 0 20 GPIO_ACTIVE_HIGH>;
++      };
++
++      aliases {
++              ethernet1 = &rtl8189etv;
++      };
++};
++
++&ohci1 {
++      /*
++       * RTL8152B USB-Ethernet adapter is connected to USB1,
++       * and it's a USB 2.0 device. So the OHCI1 controller
++       * can be left disabled.
++       */
++      status = "disabled";
++};
++
++&mmc1 {
++      vmmc-supply = <&reg_vcc3v3>;
++      vqmmc-supply = <&reg_vcc3v3>;
++
++      rtl8189etv: sdio_wifi@1 {
++              reg = <1>;
++      };
++};
++
++&usbphy {
++      usb1_vbus-supply = <&reg_vcc_usb_eth>;
++};
+--- a/board/sunxi/MAINTAINERS
++++ b/board/sunxi/MAINTAINERS
+@@ -302,6 +302,11 @@ M:        Jagan Teki <jagan@amarulasolutions.co
+ S:    Maintained
+ F:    configs/orangepi_prime_defconfig
++ORANGEPI R1 BOARD
++M:    Hauke Mehrtens <hauke@hauke-m.de>
++S:    Maintained
++F:    configs/orangepi_r1_defconfig
++
+ PINE64 BOARDS
+ M:    Andre Przywara <andre.przywara@arm.com>
+ S:    Maintained
+--- /dev/null
++++ b/configs/orangepi_r1_defconfig
+@@ -0,0 +1,18 @@
++CONFIG_ARM=y
++CONFIG_ARCH_SUNXI=y
++CONFIG_SPL_SPI_FLASH_SUPPORT=y
++CONFIG_MACH_SUN8I_H3=y
++CONFIG_DRAM_CLK=624
++CONFIG_DRAM_ZQ=3881979
++CONFIG_DRAM_ODT_EN=y
++# CONFIG_VIDEO_DE2 is not set
++CONFIG_DEFAULT_DEVICE_TREE="sun8i-h2-plus-orangepi-r1"
++# CONFIG_SYS_MALLOC_CLEAR_ON_INIT is not set
++CONFIG_CONSOLE_MUX=y
++CONFIG_SPL=y
++# CONFIG_CMD_IMLS is not set
++# CONFIG_CMD_FLASH is not set
++# CONFIG_CMD_FPGA is not set
++CONFIG_SPL_SPI_SUNXI=y
++CONFIG_SUN8I_EMAC=y
++CONFIG_USB_EHCI_HCD=y