gdb: update to version 7.12.1, fix glibc 2.25 build issues
[openwrt/staging/lynxis.git] / package / devel / gdb / patches / 110-shared_libgcc.patch
diff --git a/package/devel/gdb/patches/110-shared_libgcc.patch b/package/devel/gdb/patches/110-shared_libgcc.patch
new file mode 100644 (file)
index 0000000..e44616f
--- /dev/null
@@ -0,0 +1,76 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1406,13 +1406,13 @@ if test -z "$LD"; then
+   fi
+ fi
+-# Check whether -static-libstdc++ -static-libgcc is supported.
++# Check whether -static-libstdc++ is supported.
+ have_static_libs=no
+ if test "$GCC" = yes; then
+   saved_LDFLAGS="$LDFLAGS"
+-  LDFLAGS="$LDFLAGS -static-libstdc++ -static-libgcc"
+-  AC_MSG_CHECKING([whether g++ accepts -static-libstdc++ -static-libgcc])
++  LDFLAGS="$LDFLAGS -static-libstdc++"
++  AC_MSG_CHECKING([whether g++ accepts -static-libstdc++])
+   AC_LANG_PUSH(C++)
+   AC_LINK_IFELSE([
+ #if (__GNUC__ < 4) || (__GNUC__ == 4 && __GNUC_MINOR__ < 5)
+@@ -1740,7 +1740,7 @@ AC_ARG_WITH(stage1-ldflags,
+  # if supported.  But if the user explicitly specified the libraries to use,
+  # trust that they are doing what they want.
+  if test "$stage1_libs" = "" -a "$have_static_libs" = yes; then
+-   stage1_ldflags="-static-libstdc++ -static-libgcc"
++   stage1_ldflags="-static-libstdc++"
+  fi])
+ AC_SUBST(stage1_ldflags)
+@@ -1769,7 +1769,7 @@ AC_ARG_WITH(boot-ldflags,
+  # statically.  But if the user explicitly specified the libraries to
+  # use, trust that they are doing what they want.
+  if test "$poststage1_libs" = ""; then
+-   poststage1_ldflags="-static-libstdc++ -static-libgcc"
++   poststage1_ldflags="-static-libstdc++"
+  fi])
+ AC_SUBST(poststage1_ldflags)
+--- a/configure
++++ b/configure
+@@ -5109,14 +5109,14 @@ if test -z "$LD"; then
+   fi
+ fi
+-# Check whether -static-libstdc++ -static-libgcc is supported.
++# Check whether -static-libstdc++ is supported.
+ have_static_libs=no
+ if test "$GCC" = yes; then
+   saved_LDFLAGS="$LDFLAGS"
+-  LDFLAGS="$LDFLAGS -static-libstdc++ -static-libgcc"
+-  { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether g++ accepts -static-libstdc++ -static-libgcc" >&5
+-$as_echo_n "checking whether g++ accepts -static-libstdc++ -static-libgcc... " >&6; }
++  LDFLAGS="$LDFLAGS -static-libstdc++"
++  { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether g++ accepts -static-libstdc++" >&5
++$as_echo_n "checking whether g++ accepts -static-libstdc++... " >&6; }
+   ac_ext=cpp
+ ac_cpp='$CXXCPP $CPPFLAGS'
+ ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
+@@ -5902,7 +5902,7 @@ else
+  # if supported.  But if the user explicitly specified the libraries to use,
+  # trust that they are doing what they want.
+  if test "$stage1_libs" = "" -a "$have_static_libs" = yes; then
+-   stage1_ldflags="-static-libstdc++ -static-libgcc"
++   stage1_ldflags="-static-libstdc++"
+  fi
+ fi
+@@ -5938,7 +5938,7 @@ else
+  # statically.  But if the user explicitly specified the libraries to
+  # use, trust that they are doing what they want.
+  if test "$poststage1_libs" = ""; then
+-   poststage1_ldflags="-static-libstdc++ -static-libgcc"
++   poststage1_ldflags="-static-libstdc++"
+  fi
+ fi