strace: update to version 5.4
[openwrt/staging/wigyori.git] / package / devel / strace / Makefile
index 55fdc80c1ba35626fb8d7272a92139a7791a6ba8..0d22b0bb23d6b2ad4526c3850dfe79782a60dbd0 100644 (file)
@@ -9,18 +9,17 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=strace
-PKG_VERSION:=4.25
+PKG_VERSION:=5.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://strace.io/files/$(PKG_VERSION)
-PKG_HASH:=d685f8e65470b7832c3aff60c57ab4459f26ff89f07c10f92bd70ee89efac701
-
-PKG_LICENSE:=BSD-3c
-PKG_LICENSE_FILES:=COPYRIGHT
-PKG_CPE_ID:=cpe:/a:paul_kranenburg:strace
+PKG_HASH:=f7d00514d51290b6db78ad7a9de709baf93caa5981498924cbc9a744cfd2a741
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
+PKG_LICENSE:=LGPL-2.1-or-later
+PKG_LICENSE_FILES:=COPYING
+PKG_CPE_ID:=cpe:/a:paul_kranenburg:strace
 
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
@@ -47,27 +46,29 @@ define Package/strace
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=System call tracer
+  URL:=https://strace.io/
   DEPENDS:=+STRACE_LIBDW:libdw +STRACE_LIBUNWIND:libunwind
-  URL:=http://strace.sourceforge.net/
 endef
 
 define Package/strace/description
-A useful diagnostic, instructional, and debugging tool. Allows you to track what
-system calls a program makes while it is running.
+  A useful diagnostic, instructional, and debugging tool. Allows you to track what
+  system calls a program makes while it is running.
 endef
 
 define Package/strace/config
-menu "Select strace configuration options"
-       depends on PACKAGE_strace
+choice
+       prompt "stack tracing support"
+       default STRACE_NONE
+
+       config STRACE_NONE
+               bool "None"
 
-config STRACE_LIBDW
-       bool "Enable stack tracing support using libdw"
-       default n
-config STRACE_LIBUNWIND
-       bool "Enable stack tracing support using libunwind (experimental)"
-       default n
+       config STRACE_LIBDW
+               bool "libdw"
 
-endmenu
+       config STRACE_LIBUNWIND
+               bool "libunwind (experimental)"
+endchoice
 endef
 
 CONFIGURE_ARGS += \