strace: Update to version 5.8
[openwrt/staging/wigyori.git] / package / devel / strace / Makefile
index 55fdc80c1ba35626fb8d7272a92139a7791a6ba8..1a0c0f442f37df5630401d08976ffa4ebea6de08 100644 (file)
@@ -9,18 +9,17 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=strace
-PKG_VERSION:=4.25
+PKG_VERSION:=5.8
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://strace.io/files/$(PKG_VERSION)
-PKG_HASH:=d685f8e65470b7832c3aff60c57ab4459f26ff89f07c10f92bd70ee89efac701
-
-PKG_LICENSE:=BSD-3c
-PKG_LICENSE_FILES:=COPYRIGHT
-PKG_CPE_ID:=cpe:/a:paul_kranenburg:strace
+PKG_HASH:=df4a669f7fff9cc302784085bd4b72fab216a426a3f72c892b28a537b71e7aa9
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
+PKG_LICENSE:=LGPL-2.1-or-later
+PKG_LICENSE_FILES:=COPYING
+PKG_CPE_ID:=cpe:/a:paul_kranenburg:strace
 
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
@@ -33,10 +32,6 @@ include $(INCLUDE_DIR)/package.mk
 
 HOST_CFLAGS += -I$(LINUX_DIR)/user_headers/include
 
-ifeq ($(ARCH),aarch64)
-  CONFIGURE_ARGS += --enable-mpers=check
-endif
-
 CONFIGURE_VARS+= \
        LDFLAGS_FOR_BUILD="$(HOST_LDFLAGS)" \
        CPPFLAGS_FOR_BUILD="$(HOST_CPPFLAGS)" \
@@ -47,32 +42,35 @@ define Package/strace
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=System call tracer
+  URL:=https://strace.io/
   DEPENDS:=+STRACE_LIBDW:libdw +STRACE_LIBUNWIND:libunwind
-  URL:=http://strace.sourceforge.net/
 endef
 
 define Package/strace/description
-A useful diagnostic, instructional, and debugging tool. Allows you to track what
-system calls a program makes while it is running.
+  A useful diagnostic, instructional, and debugging tool. Allows you to track what
+  system calls a program makes while it is running.
 endef
 
 define Package/strace/config
-menu "Select strace configuration options"
-       depends on PACKAGE_strace
+choice
+       prompt "stack tracing support"
+       default STRACE_NONE
+
+       config STRACE_NONE
+               bool "None"
 
-config STRACE_LIBDW
-       bool "Enable stack tracing support using libdw"
-       default n
-config STRACE_LIBUNWIND
-       bool "Enable stack tracing support using libunwind (experimental)"
-       default n
+       config STRACE_LIBDW
+               bool "libdw"
 
-endmenu
+       config STRACE_LIBUNWIND
+               bool "libunwind (experimental)"
+endchoice
 endef
 
 CONFIGURE_ARGS += \
        --with-libdw=$(if $(CONFIG_STRACE_LIBDW),yes,no) \
-       --with-libunwind=$(if $(CONFIG_STRACE_LIBUNWIND),yes,no)
+       --with-libunwind=$(if $(CONFIG_STRACE_LIBUNWIND),yes,no) \
+       --enable-mpers=no
 
 MAKE_FLAGS := \
        CCOPT="$(TARGET_CFLAGS)"