strace: Update to version 5.8
[openwrt/staging/wigyori.git] / package / devel / strace / Makefile
index ded6d3bb843c96b777f83232649f25dbedd9094a..1a0c0f442f37df5630401d08976ffa4ebea6de08 100644 (file)
@@ -9,31 +9,29 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=strace
-PKG_VERSION:=4.24
+PKG_VERSION:=5.8
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://strace.io/files/$(PKG_VERSION)
-PKG_HASH:=1f4e59fc1edfa2bfb4adf2a748623dc25b105ec79713dd84404199f91b0b0634
-
-PKG_LICENSE:=BSD-3c
-PKG_LICENSE_FILES:=COPYRIGHT
-PKG_CPE_ID:=cpe:/a:paul_kranenburg:strace
+PKG_HASH:=df4a669f7fff9cc302784085bd4b72fab216a426a3f72c892b28a537b71e7aa9
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
+PKG_LICENSE:=LGPL-2.1-or-later
+PKG_LICENSE_FILES:=COPYING
+PKG_CPE_ID:=cpe:/a:paul_kranenburg:strace
 
 PKG_FIXUP:=autoreconf
-PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_strace_libunwind
 PKG_INSTALL:=1
 
+PKG_CONFIG_DEPENDS := \
+       CONFIG_STRACE_LIBDW \
+       CONFIG_STRACE_LIBUNWIND
+
 include $(INCLUDE_DIR)/package.mk
 
 HOST_CFLAGS += -I$(LINUX_DIR)/user_headers/include
 
-ifeq ($(ARCH),aarch64)
-  CONFIGURE_ARGS += --enable-mpers=check
-endif
-
 CONFIGURE_VARS+= \
        LDFLAGS_FOR_BUILD="$(HOST_LDFLAGS)" \
        CPPFLAGS_FOR_BUILD="$(HOST_CPPFLAGS)" \
@@ -44,22 +42,36 @@ define Package/strace
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=System call tracer
-  DEPENDS:=+PACKAGE_strace_libunwind:libunwind
-  URL:=http://strace.sourceforge.net/
+  URL:=https://strace.io/
+  DEPENDS:=+STRACE_LIBDW:libdw +STRACE_LIBUNWIND:libunwind
 endef
 
 define Package/strace/description
-A useful diagnostic, instructional, and debugging tool. Allows you to track what
-system calls a program makes while it is running.
+  A useful diagnostic, instructional, and debugging tool. Allows you to track what
+  system calls a program makes while it is running.
 endef
 
 define Package/strace/config
-config PACKAGE_strace_libunwind
-       bool "Enable stack tracing support using libunwind (experimental)"
-       default n
+choice
+       prompt "stack tracing support"
+       default STRACE_NONE
+
+       config STRACE_NONE
+               bool "None"
+
+       config STRACE_LIBDW
+               bool "libdw"
+
+       config STRACE_LIBUNWIND
+               bool "libunwind (experimental)"
+endchoice
 endef
 
-CONFIGURE_ARGS += --with-libunwind=$(if $(CONFIG_PACKAGE_strace_libunwind),yes,no)
+CONFIGURE_ARGS += \
+       --with-libdw=$(if $(CONFIG_STRACE_LIBDW),yes,no) \
+       --with-libunwind=$(if $(CONFIG_STRACE_LIBUNWIND),yes,no) \
+       --enable-mpers=no
+
 MAKE_FLAGS := \
        CCOPT="$(TARGET_CFLAGS)"