strace: Update to 4.20
[openwrt/staging/mkresin.git] / package / devel / strace / Makefile
index eb80791b2686fee82327895243d05a7cac412a0a..6209dc5a638f879625c63971f772abee83c0f44d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,28 +9,38 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=strace
-
-PKG_VERSION:=4.10
+PKG_VERSION:=4.20
 PKG_RELEASE:=1
-PKG_MD5SUM:=107a5be455493861189e9b57a3a51912
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_HASH:=5bf3148dd17306a42566f7da17368fdd781afa147db05ea63a4ca2b50f58c523
 
 PKG_LICENSE:=BSD-3c
 PKG_LICENSE_FILES:=COPYRIGHT
+PKG_CPE_ID:=cpe:/a:paul_kranenburg:strace
 
-PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 
 PKG_FIXUP:=autoreconf
+PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_strace_libunwind
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
+HOST_CFLAGS += -I$(LINUX_DIR)/user_headers/include
+
+CONFIGURE_VARS+= \
+       LDFLAGS_FOR_BUILD="$(HOST_LDFLAGS)" \
+       CPPFLAGS_FOR_BUILD="$(HOST_CPPFLAGS)" \
+       CFLAGS_FOR_BUILD="$(HOST_CFLAGS)" \
+       CC_FOR_BUILD="$(HOST_CC)"
+
 define Package/strace
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=System call tracer
+  DEPENDS:=+PACKAGE_strace_libunwind:libunwind
   URL:=http://strace.sourceforge.net/
 endef
 
@@ -39,6 +49,13 @@ A useful diagnostic, instructional, and debugging tool. Allows you to track what
 system calls a program makes while it is running.
 endef
 
+define Package/strace/config
+config PACKAGE_strace_libunwind
+       bool "Enable stack tracing support using libunwind (experimental)"
+       default n
+endef
+
+CONFIGURE_ARGS += --with-libunwind=$(if $(CONFIG_PACKAGE_strace_libunwind),yes,no)
 MAKE_FLAGS := \
        CCOPT="$(TARGET_CFLAGS)"