strace: update to version 1.12
[openwrt/staging/wigyori.git] / package / devel / strace / Makefile
index 8a0d2e8fb302d50fd3c8c9b94f8316cb597ec88f..6d9a7be5342caf8e30595820ca78137f3d4d60f6 100644 (file)
@@ -10,9 +10,9 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=strace
 
-PKG_VERSION:=4.11
+PKG_VERSION:=4.12
 PKG_RELEASE:=1
-PKG_MD5SUM:=a15d2555a7febb56d00c6e1a51c655dc
+PKG_MD5SUM:=efb8611fc332e71ec419c53f59faa93e
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
@@ -23,6 +23,7 @@ PKG_LICENSE_FILES:=COPYRIGHT
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 
 PKG_FIXUP:=autoreconf
+PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_strace_libunwind
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -39,6 +40,7 @@ define Package/strace
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=System call tracer
+  DEPENDS:=+PACKAGE_strace_libunwind:libunwind
   URL:=http://strace.sourceforge.net/
 endef
 
@@ -47,6 +49,13 @@ A useful diagnostic, instructional, and debugging tool. Allows you to track what
 system calls a program makes while it is running.
 endef
 
+define Package/strace/config
+config PACKAGE_strace_libunwind
+       bool "Enable stack tracing support using libunwind (experimental)"
+       default n
+endef
+
+CONFIGURE_ARGS += --with-libunwind=$(if $(CONFIG_PACKAGE_strace_libunwind),yes,no)
 MAKE_FLAGS := \
        CCOPT="$(TARGET_CFLAGS)"