trace-cmd: update to v3.1.2
[openwrt/staging/noltari.git] / package / devel / trace-cmd / Makefile
index e15b04ad23a7b8268b672ffb8d0a79e68e525d7c..c9b0dc980b5a828de596e9697b9770f805fc72d0 100644 (file)
@@ -1,12 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=trace-cmd
-PKG_VERSION:=v2.9.1
+PKG_VERSION:=v3.1.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/rostedt/trace-cmd.git/snapshot/
-PKG_HASH:=9404fc3cf540ea795304608068c9db6cdb38b90584c7f3c43249785913d54b38
+PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/utils/trace-cmd/trace-cmd.git/snapshot/
+PKG_HASH:=206672af60aa0bc35cfc44a4be746efa575bac729060e54b6453f7d5dfbcd979
 
 PKG_LICENSE:=GPL-2.0-only
 PKG_LICENSE_FILES:=COPYING
@@ -21,14 +21,14 @@ define Package/trace-cmd
   SECTION:=devel
   CATEGORY:=Development
   TITLE:=Linux trace command line utility
-  DEPENDS:=
+  DEPENDS:=+libtracefs +zlib
 endef
 
 define Package/trace-cmd-extra
   SECTION:=devel
   CATEGORY:=Development
   TITLE:=Extra plugins for trace-cmd
-  DEPENDS:=
+  DEPENDS:=+libtraceevent-extra
 endef
 
 MAKE_FLAGS += \
@@ -36,27 +36,11 @@ MAKE_FLAGS += \
        NO_AUDIT=1 \
        prefix=/usr
 
-PLUGINS_DIR := $(PKG_INSTALL_DIR)/usr/lib/traceevent/plugins
-PLUGINS_MAIN := function hrtimer mac80211 sched_switch
-
 TARGET_CFLAGS += --std=gnu99 -D_GNU_SOURCE
 
 define Package/trace-cmd/install
        $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/lib/traceevent/plugins
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/trace-cmd $(1)/usr/bin/
-       $(CP) \
-               $(patsubst %,$(PLUGINS_DIR)/plugin_%.so,$(PLUGINS_MAIN)) \
-               $(1)/usr/lib/traceevent/plugins
-endef
-
-define Package/trace-cmd-extra/install
-       $(INSTALL_DIR) $(1)/usr/lib/traceevent/plugins
-       $(CP) \
-               $$(patsubst %,$(PLUGINS_DIR)/plugin_%.so, \
-                       $$(filter-out $(PLUGINS_MAIN), \
-                               $$(patsubst $(PLUGINS_DIR)/plugin_%.so,%, \
-                                       $$(wildcard $(PLUGINS_DIR)/plugin_*.so)))) \
-               $(1)/usr/lib/traceevent/plugins
 endef
 
 $(eval $(call BuildPackage,trace-cmd))