disable mips16 for a few packages that don't compile with it
[openwrt/openwrt.git] / package / devel / trace-cmd / Makefile
index c201eb0ecdfbc8a9726ff27d0a6e3a1968a12466..6bd70e97b5e1c9961d33eed86bfb16789fb20d2a 100644 (file)
@@ -1,16 +1,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=trace-cmd
-PKG_VERSION:=v2.0.1
+PKG_VERSION:=v2.2.1
 PKG_RELEASE=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://git.kernel.org/pub/scm/linux/kernel/git/rostedt/trace-cmd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=1776cf9a24f95b2623fe7ee380d708bb8c6d8a73
+PKG_SOURCE_VERSION:=8c10a774f1f8586cd8b0e3ce8666a376cb1d98e3
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 # PKG_MIRROR_MD5SUM:=6a08dfa2519a969d184e7bb5bb390620
 PKG_INSTALL:=1
+PKG_USE_MIPS16:=0
 
 PKG_BUILD_PARALLEL:=1
 
@@ -35,11 +36,9 @@ MAKE_FLAGS += \
        prefix=/usr
 
 PLUGINS_DIR := $(PKG_INSTALL_DIR)/usr/lib/trace-cmd/plugins
-PLUGINS_ALL = $(patsubst $(PLUGINS_DIR)/plugin_%.so,%,$(wildcard $(PLUGINS_DIR)/plugin_*.so))
 PLUGINS_MAIN := function hrtimer mac80211 sched_switch
-PLUGINS_EXTRA = $(filter-out $(PLUGINS_MAIN),$(PLUGINS_ALL))
 
-TARGET_CFLAGS += --std=gnu99
+TARGET_CFLAGS += --std=gnu99 -D_GNU_SOURCE
 
 define Package/trace-cmd/install
        $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/lib/trace-cmd/plugins
@@ -52,7 +51,10 @@ endef
 define Package/trace-cmd-extra/install
        $(INSTALL_DIR) $(1)/usr/lib/trace-cmd/plugins
        $(CP) \
-               $(patsubst %,$(PLUGINS_DIR)/plugin_%.so,$(PLUGINS_EXTRA)) \
+               $$(patsubst %,$(PLUGINS_DIR)/plugin_%.so, \
+                       $$(filter-out $(PLUGINS_MAIN), \
+                               $$(patsubst $(PLUGINS_DIR)/plugin_%.so,%, \
+                                       $$(wildcard $(PLUGINS_DIR)/plugin_*.so)))) \
                $(1)/usr/lib/trace-cmd/plugins
 endef