add file type autodetection for the unpack command and nuke PKG_CAT:= in lots of...
[openwrt/staging/florian.git] / package / e2fsprogs / Makefile
index a53e98cf1ce2060f06933b8b67b014fad7a61786..83e609eaf9977dd10b1ca0c9404e23220f78926d 100644 (file)
@@ -9,16 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=e2fsprogs
-PKG_VERSION:=1.38
+PKG_VERSION:=1.39
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/e2fsprogs
-PKG_MD5SUM:=d774d4412bfb80d12cf3a4fdfd59de5a
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=06f7806782e357797fad1d34b7ced0c6
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -47,15 +43,12 @@ define Package/resize2fs
   DEPENDS:=e2fsprogs
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --disable-rpath \
-               --enable-elf-shlibs \
-               --enable-dynamic-e2fsck \
-       )
-endef
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --disable-rpath \
+       --enable-elf-shlibs \
+       --enable-dynamic-e2fsck
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)/util \