finally kill KMOD_template - removes a big chunk of legacy build code
[openwrt/svn-archive/archive.git] / package / kernel / Makefile
index 37cb13e167c3d2b8c38db2db6c767de68f0c8f55..a030ad7236d13d2365f2e84714655d13e1d39d05 100644 (file)
@@ -32,5 +32,27 @@ endef
 define Build/Compile
 endef
 
+CONFIG_PACKAGE_kernel=y
+define Package/kernel
+  SECTION:=sys
+  CATEGORY:=Kernel
+  DEFAULT:=y
+  TITLE:=Virtual kernel package
+  DESCRIPTION:=Virtual kernel package
+  VERSION:=$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)
+endef
+
+define Package/kernel/install
+  # nothing to do
+endef
+
+# this is more robust than ifdef around eval/call
+ifneq ($(DUMP),1)
+  define BuildKernel
+    $(call BuildPackage,kernel)
+  endef
+endif
+$(eval $(call BuildKernel))
+
 include $(TOPDIR)/target/linux/*/modules.mk
 include ./modules/*.mk