kernel: make kmod package dependencies forward compatible
[openwrt/staging/yousong.git] / package / kernel / linux / modules / block.mk
index 508b3abd5d772a462e37b758d123aa30e126d59d..62f08218c690778651cb57ae4fe90f360001b5e7 100644 (file)
@@ -326,7 +326,7 @@ $(eval $(call KernelPackage,md-raid10))
 
 
 define KernelPackage/md-raid456
-$(call KernelPackage/md/Depends,+kmod-lib-raid6 +kmod-lib-xor +LINUX_4_4:kmod-lib-crc32c)
+$(call KernelPackage/md/Depends,+kmod-lib-raid6 +kmod-lib-xor +!LINUX_3_18:kmod-lib-crc32c)
   TITLE:=RAID Level 456 Driver
   KCONFIG:= \
        CONFIG_ASYNC_CORE \