kernel: move crypto-arc4 into a module
[openwrt/staging/wigyori.git] / package / kernel / linux / modules / crypto.mk
index 17cb98302d9fa7d6886f1019a7fe9e045ac81cd9..dc7eb77986780aa52886ff2015bedc3b4f9f7656 100644 (file)
@@ -46,6 +46,17 @@ endef
 $(eval $(call KernelPackage,crypto-aead))
 
 
+define KernelPackage/crypto-arc4
+  TITLE:=ARC4 cipher CryptoAPI module
+  KCONFIG:=CONFIG_CRYPTO_ARC4
+  FILES:=$(LINUX_DIR)/crypto/arc4.ko
+  AUTOLOAD:=$(call AutoLoad,09,arc4)
+  $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-arc4))
+
+
 define KernelPackage/crypto-authenc
   TITLE:=Combined mode wrapper for IPsec
   DEPENDS:=+kmod-crypto-manager +kmod-crypto-null