omap24xx: Remove unmaintained target
[openwrt/openwrt.git] / package / kernel / linux / modules / crypto.mk
index 4892f1493264262451100b33cf784e401c70f15b..fef9ea0ebff4dc1bd32ac028104680accc99f862 100644 (file)
@@ -226,6 +226,18 @@ endef
 $(eval $(call KernelPackage,crypto-gcm))
 
 
+define KernelPackage/crypto-xcbc
+  TITLE:=XCBC CryptoAPI module
+  DEPENDS:=+kmod-crypto-hash +kmod-crypto-manager
+  KCONFIG:=CONFIG_CRYPTO_XCBC
+  FILES:=$(LINUX_DIR)/crypto/xcbc.ko
+  AUTOLOAD:=$(call AutoLoad,09,xcbc)
+  $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-xcbc))
+
+
 define KernelPackage/crypto-gf128
   TITLE:=GF(2^128) multiplication functions CryptoAPI module
   KCONFIG:=CONFIG_CRYPTO_GF128MUL
@@ -274,7 +286,7 @@ $(eval $(call KernelPackage,crypto-hmac))
 
 define KernelPackage/crypto-hw-ccp
   TITLE:=AMD Cryptographic Coprocessor
-  DEPENDS:=+kmod-crypto-authenc +kmod-crypto-hash +kmod-crypto-manager +kmod-random-core +kmod-crypto-sha1 +kmod-crypto-sha256 +LINUX_4_14:kmod-crypto-rsa
+  DEPENDS:=+kmod-crypto-authenc +kmod-crypto-hash +kmod-crypto-manager +kmod-random-core +kmod-crypto-sha1 +kmod-crypto-sha256 +!(LINUX_3_18||LINUX_4_9):kmod-crypto-rsa
   KCONFIG:= \
        CONFIG_CRYPTO_HW=y \
        CONFIG_CRYPTO_DEV_CCP=y \
@@ -500,10 +512,11 @@ ifndef CONFIG_TARGET_x86_64
        $(LINUX_DIR)/arch/x86/crypto/twofish-i586.ko \
        $(LINUX_DIR)/arch/x86/crypto/serpent-sse2-i586.ko \
        $(LINUX_DIR)/arch/x86/crypto/glue_helper.ko \
-       $(LINUX_DIR)/crypto/ablk_helper.ko \
+       $(LINUX_DIR)/crypto/ablk_helper.ko@lt4.17 \
        $(LINUX_DIR)/crypto/cryptd.ko \
-       $(LINUX_DIR)/crypto/lrw.ko
-    AUTOLOAD+= $(call AutoLoad,10,lrw cryptd ablk_helper glue_helper \
+       $(LINUX_DIR)/crypto/lrw.ko@lt4.17 \
+       $(LINUX_DIR)/crypto/crypto_simd.ko@ge4.17
+    AUTOLOAD+= $(call AutoLoad,10,cryptd glue_helper \
        serpent-sse2-i586 twofish-i586 blowfish_generic)
   endef
 endif
@@ -522,8 +535,8 @@ define KernelPackage/crypto-misc/x86/64
        $(LINUX_DIR)/arch/x86/crypto/serpent-avx-x86_64.ko \
        $(LINUX_DIR)/arch/x86/crypto/camellia-aesni-avx2.ko \
        $(LINUX_DIR)/arch/x86/crypto/serpent-avx2.ko \
-       $(LINUX_DIR)/crypto/ablk_helper.ko
-  AUTOLOAD+= $(call AutoLoad,10,ablk_helper camellia-x86_64 \
+       $(LINUX_DIR)/crypto/ablk_helper.ko@lt4.17
+  AUTOLOAD+= $(call AutoLoad,10,camellia-x86_64 \
        camellia-aesni-avx-x86_64 camellia-aesni-avx2 cast5-avx-x86_64 \
        cast6-avx-x86_64 twofish-x86_64 twofish-x86_64-3way \
        twofish-avx-x86_64 blowfish-x86_64 serpent-avx-x86_64 serpent-avx2)
@@ -584,6 +597,18 @@ endef
 $(eval $(call KernelPackage,crypto-rsa))
 
 
+define KernelPackage/crypto-rmd160
+  TITLE:=RIPEMD160 digest CryptoAPI module
+  DEPENDS:=+kmod-crypto-hash
+  KCONFIG:=CONFIG_CRYPTO_RMD160
+  FILES:=$(LINUX_DIR)/crypto/rmd160.ko
+  AUTOLOAD:=$(call AutoLoad,09,rmd160)
+  $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-rmd160))
+
+
 define KernelPackage/crypto-rng
   TITLE:=CryptoAPI random number generation
   DEPENDS:=+kmod-crypto-hash +kmod-crypto-hmac +kmod-crypto-sha256