kernel: wpan: Add missing AUTOLOAD to load kernel module
[openwrt/staging/wigyori.git] / package / kernel / linux / modules / fs.mk
index ebf8677d93fdac9b0de680cd6f888981d2de4da9..84dc498365dbefea6f733c08634674e6d3371d84 100644 (file)
@@ -49,8 +49,12 @@ $(eval $(call KernelPackage,fs-afs))
 define KernelPackage/fs-autofs4
   SUBMENU:=$(FS_MENU)
   TITLE:=AUTOFS4 filesystem support
-  KCONFIG:=CONFIG_AUTOFS4_FS
-  FILES:=$(LINUX_DIR)/fs/autofs4/autofs4.ko
+  KCONFIG:= \
+       CONFIG_AUTOFS4_FS \
+       CONFIG_AUTOFS_FS
+  FILES:= \
+       $(LINUX_DIR)/fs/autofs4/autofs4.ko@lt4.18 \
+       $(LINUX_DIR)/fs/autofs/autofs4.ko@ge4.18
   AUTOLOAD:=$(call AutoLoad,30,autofs4)
 endef
 
@@ -64,7 +68,7 @@ $(eval $(call KernelPackage,fs-autofs4))
 define KernelPackage/fs-btrfs
   SUBMENU:=$(FS_MENU)
   TITLE:=BTRFS filesystem support
-  DEPENDS:=+kmod-lib-crc32c +kmod-lib-lzo +kmod-lib-zlib-inflate +kmod-lib-zlib-deflate +kmod-lib-raid6 +kmod-lib-xor +LINUX_4_14:kmod-lib-zstd
+  DEPENDS:=+kmod-lib-crc32c +kmod-lib-lzo +kmod-lib-zlib-inflate +kmod-lib-zlib-deflate +kmod-lib-raid6 +kmod-lib-xor +kmod-lib-zstd
   KCONFIG:=\
        CONFIG_BTRFS_FS \
        CONFIG_BTRFS_FS_POSIX_ACL=n \
@@ -94,6 +98,7 @@ define KernelPackage/fs-cifs
   AUTOLOAD:=$(call AutoLoad,30,cifs)
   $(call AddDepends/nls)
   DEPENDS+= \
+    +kmod-crypto-arc4 \
     +kmod-crypto-hmac \
     +kmod-crypto-md5 \
     +kmod-crypto-md4 \
@@ -201,7 +206,7 @@ $(eval $(call KernelPackage,fs-ext4))
 define KernelPackage/fs-f2fs
   SUBMENU:=$(FS_MENU)
   TITLE:=F2FS filesystem support
-  DEPENDS:= +kmod-crypto-hash +kmod-crypto-crc32
+  DEPENDS:= +kmod-crypto-hash +kmod-crypto-crc32 +LINUX_5_4:kmod-nls-base
   KCONFIG:= \
        CONFIG_F2FS_FS \
        CONFIG_F2FS_STAT_FS=y \
@@ -384,7 +389,8 @@ define KernelPackage/fs-nfs-common-rpcsec
        +kmod-crypto-md5 \
        +kmod-crypto-sha1 \
        +kmod-crypto-hmac \
-       +kmod-crypto-ecb
+       +kmod-crypto-ecb \
+       +kmod-crypto-arc4
   KCONFIG:= \
        CONFIG_SUNRPC_GSS \
        CONFIG_RPCSEC_GSS_KRB5