kernel: modules: gpio.mk: renamed from gpio-cascade.mk
[openwrt/staging/wigyori.git] / package / kernel / linux / modules / gpio.mk
diff --git a/package/kernel/linux/modules/gpio.mk b/package/kernel/linux/modules/gpio.mk
new file mode 100644 (file)
index 0000000..62d2688
--- /dev/null
@@ -0,0 +1,20 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+GPIO_MENU:=GPIO support
+
+define KernelPackage/gpio-cascade
+  SUBMENU:=$(GPIO_MENU)
+  TITLE:=Generic GPIO cascade
+  KCONFIG:=CONFIG_GPIO_CASCADE
+  DEPENDS:=@GPIO_SUPPORT +kmod-mux-core
+  FILES:=$(LINUX_DIR)/drivers/gpio/gpio-cascade.ko
+  AUTOLOAD:=$(call AutoLoad,29,gpio-cascade,1)
+endef
+
+define KernelPackage/gpio-cascade/description
+  Kernel module for Generic GPIO cascade
+endef
+
+$(eval $(call KernelPackage,gpio-cascade))