kernel: make kmod package dependencies forward compatible
[openwrt/staging/yousong.git] / package / kernel / linux / modules / hwmon.mk
index e2962058aaaedcd1564fe5b75bf9f8e14f2be15b..8fdf62446d27f0165220c33a982b624c58d16dfc 100644 (file)
@@ -98,7 +98,7 @@ define KernelPackage/hwmon-ina2xx
   KCONFIG:=CONFIG_SENSORS_INA2XX
   FILES:=$(LINUX_DIR)/drivers/hwmon/ina2xx.ko
   AUTOLOAD:=$(call AutoProbe,ina2xx)
-  $(call AddDepends/hwmon,+kmod-i2c-core +LINUX_4_4:kmod-regmap)
+  $(call AddDepends/hwmon,+kmod-i2c-core +!LINUX_3_18:kmod-regmap)
 endef
 
 define KernelPackage/hwmon-ina2xx/description