kernel: make kmod-gpiofan depend on kmod-thermal to fix build errors
[openwrt/staging/yousong.git] / package / kernel / linux / modules / hwmon.mk
index ca0ff661726dcd4b0a5d1cd4763d29715e9f6393..ad1c7bf91d108f9896781ca87f10716df568e2fa 100644 (file)
@@ -274,7 +274,7 @@ define KernelPackage/hwmon-gpiofan
   KCONFIG:=CONFIG_SENSORS_GPIO_FAN
   FILES:=$(LINUX_DIR)/drivers/hwmon/gpio-fan.ko
   AUTOLOAD:=$(call AutoLoad,60,gpio-fan)
-  $(call AddDepends/hwmon,+kmod-i2c-core)
+  $(call AddDepends/hwmon,+kmod-i2c-core +kmod-thermal)
 endef
 
 define KernelPackage/hwmon-gpiofan/description