kernel: drop obsolete linux 3.10 related dependencies/checks
[openwrt/staging/wigyori.git] / package / kernel / linux / modules / hwmon.mk
index 5b7936a9f07f6beee441c8a2efd70bcfaf7d3e5a..971e653855d4763ccd122f7d6865b3d3f4e92989 100644 (file)
@@ -46,7 +46,6 @@ $(eval $(call KernelPackage,hwmon-vid))
 
 define KernelPackage/hwmon-adt7410
   TITLE:=ADT7410 monitoring support
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.10.0)),1)
   KCONFIG:= \
        CONFIG_SENSORS_ADT7X10 \
        CONFIG_SENSORS_ADT7410
@@ -54,12 +53,7 @@ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.10.0)),1)
        $(LINUX_DIR)/drivers/hwmon/adt7x10.ko \
        $(LINUX_DIR)/drivers/hwmon/adt7410.ko
   AUTOLOAD:=$(call AutoLoad,60,adt7x10 adt7410)
-else
-  KCONFIG:=CONFIG_SENSORS_ADT7410
-  FILES:=$(LINUX_DIR)/drivers/hwmon/adt7410.ko
-  AUTOLOAD:=$(call AutoLoad,60,adt7410)
-endif
-  $(call AddDepends/hwmon,+kmod-i2c-core @!(LINUX_3_3||LINUX_3_6))
+  $(call AddDepends/hwmon,+kmod-i2c-core)
 endef
 
 define KernelPackage/hwmon-adt7410/description
@@ -290,6 +284,22 @@ endef
 $(eval $(call KernelPackage,hwmon-gpiofan))
 
 
+define KernelPackage/hwmon-pwmfan
+  TITLE:=Generic PWM FAN support
+  KCONFIG:=CONFIG_SENSORS_PWM_FAN
+  FILES:=$(LINUX_DIR)/drivers/hwmon/pwm-fan.ko
+  AUTOLOAD:=$(call AutoLoad,60,pwm-fan)
+  $(call AddDepends/hwmon,)
+  DEPENDS+=@!LINUX_3_14
+endef
+
+define KernelPackage/hwmon-pwmfan/description
+  Kernel module for PWM controlled FANs
+endef
+
+$(eval $(call KernelPackage,hwmon-pwmfan))
+
+
 define KernelPackage/hwmon-k10temp
   TITLE:=AMD Family 10h+ temperature sensor
   KCONFIG:=CONFIG_SENSORS_K10TEMP